Cannot be restored. This device is not eligible for the requested build 4.0.2 ->4.0.1

Discussion in 'Jailbreaks and iOS Hacks' started by palckofv, Aug 26, 2010.

  1. palckofv macrumors regular

    Joined:
    Nov 22, 2008
    #1
    So my buddy taught me how to downgrade my firmware today so I could jailbreak... I just got my iphone 4 and it came with 4.0.2. I'm really wanting to jailbreak so I tried to restore with a 4.0.1 firmware download and I got the error message: Cannot be restored. This device is not eligible for the requested build. Is there any way around this? Or do I just have to wait? I'm doing this on a mac. Thanks very much for any help
     
  2. thelatinist macrumors 603

    thelatinist

    Joined:
    Aug 15, 2009
    Location:
    Connecticut, USA
    #2
    You cannot downgrade because Apple is no longer signing installation requests for version 4.0.1. Only those who saved their 4.0.1 signature hashes before Apple stopped signing on August 19 can now downgrade. You're SOL.
     
  3. celticpride678

    Joined:
    Feb 15, 2009
    Location:
    Boston, MA
    #3
    Apple stopped signing iOS 4.0.1 already. You can't downgrade.
     
  4. Krafty macrumors 601

    Krafty

    Joined:
    Dec 31, 2007
    Location:
    La La Land
    #4
    The dev's have also stated that they aren't planning on jailbreaking 4.0.2. You're gonna have to wait until 4.1.
     
  5. mikeee macrumors regular

    Joined:
    Feb 27, 2010
    #5
    darn it, im just like you! my iphone came with 4.0.2, so any of guys may have a clue when apple will release firm 4.1? :D
     
  6. celticpride678

    Joined:
    Feb 15, 2009
    Location:
    Boston, MA
    #6
    Most likely next month. But it could take weeks until a jailbreak is released.
     
  7. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.

Share This Page