Cannot boot - Stuck with CD

Discussion in 'Mac Basics and Help' started by eye4nature, Dec 31, 2008.

  1. eye4nature macrumors newbie

    Joined:
    Dec 31, 2008
    #1
    I tried installing Leopard on my Intel 2006 iMac.
    After restart the disk wont boot, i cannot eject it and i cannot boot at all.
    The only thing that works is Command + S that brings me to a black screen with an option to type commands but i have no idea what to do ? Very frustrating, please help !

    Thank you
     
  2. finnschi macrumors 6502

    Joined:
    Dec 30, 2008
    Location:
    Hamburg, Germany
    #2
    Hold the eject button while booting, it will Force eject any cd...
    Also Try holding down option(Alt) and you will get a boot menu...

    * X during startup - Force Mac OS X startup
    * option - (eventually) brings up a screen with startup volume choices
    * Option-Command-Shift-Delete - Bypass primary startup volume and seek a different startup volume (such as a CD or external disk)
    * C - Start up from a CD that has a system folder
    * N - Attempt to start up from a compatible network server (NetBoot)
    * T - Start up in FireWire Target Disk mode (very handy for plugging your Mac into another as an external hard drive)
    * Shift - start up in Safe Boot mode and temporarily disable login items and non-essential kernel extension files (Mac OS X 10.2 and later)
    * Command-V - Start up in Verbose mode.
    * Command-S - Start up in Single-User mode
    * cmd-opt-p-r - Zap PRAM. Hold down until second chime.
    * cmd-opt-n-v - Clear NV RAM. Similar to reset-all in Open Firmware.
    * cmd-opt-o-f - Boot into open firmware
    * hold mouse click - force eject a CD/DVD


    Hope this will help you :apple:
     
  3. finnschi macrumors 6502

    Joined:
    Dec 30, 2008
    Location:
    Hamburg, Germany
    #3
    You will get a black boot screen, so you see whats going on instead of just seeing the gray apple bootscreen, so you can see the error message like "no boot media found" or cant get root device... something like that, than post the output of the file here :cool:
     
  4. gmanterry macrumors regular

    gmanterry

    Joined:
    May 31, 2008
    Location:
    Phoenix, AZ
    #4
    Here are a couple of sugestions:

    Have you tried to reboot while holding down the mouse button? Thyat should eject the disk. Check this out:

    http://www.raymond.cc/blog/archives...ct-a-stuck-cd-or-dvd-from-macbook-superdrive/

    Also have you tried holding down the "Option" key while booting. That should allow you to select the boot device. Once it has booted from the HD, you can probably eject the disk. Hope this helps. Happy New Year.

    Terry
     

Share This Page