Cannot boot Windows on Velocity Solo

Discussion in 'Mac Pro' started by StormImpact, Dec 5, 2014.

  1. StormImpact macrumors newbie

    Joined:
    May 4, 2009
    #1
    I just installed two Apricorn Velocity Solo x2s in my Mac Pro 4,1. I put one Crucial MX100 512GB in each. I was able to restore Mac OS X 10.10 to the first one and boot to it no problem.

    However, I am struggling to get Windows 7 to boot on the second drive. I installed Windows 7 and booted to it just fine while the drive was plugged into one of the internal ports. As soon as I move the drive to the Velocity Solo card and reboot I get the message: “No Boot Drive Found” when trying to boot Windows. The drive still shows up when I hold option when booting.

    Am I missing a step? I have read through the threads here about the Velocity Solo cards but I haven’t figured out what I should try next.

    Thanks,
    Impact
     
  2. hfg macrumors 68040

    hfg

    Joined:
    Dec 1, 2006
    Location:
    Cedar Rapids, IA. USA
    #2
    Did you boot Windows on the internal port WHILE one/both of the Solo x2 cards was plugged in to allow Windows to load the driver for that card?

    Any other cards in your system?
     
  3. AidenShaw macrumors P6

    AidenShaw

    Joined:
    Feb 8, 2003
    Location:
    The Peninsula
    #3
    Have you tried this yet?

    The "No Boot Drive Found" partway through booting happens when the boot code switches from the BIOS disk commands to the OS driver - and the OS driver is missing or not set to start.

    The disk driver needs to be installed and set to "boot start" in the registry in order for the switch to be successful. This should happen automatically if Windows is booted (from the internal port) and the Solo *and* disk are present.
     
  4. boodaddyz, Dec 6, 2014
    Last edited: Dec 6, 2014

    boodaddyz macrumors member

    boodaddyz

    Joined:
    Dec 25, 2008
    #4
    I am having the same issue as "No boot drive found" with Windows 8.1 Pro and my X2 card. My SSD boots into windows fine installed on the Mac Sata II slot. This sounds like a great fix, but I am having problems understanding what you mean by. "The disk driver needs to be installed and set to "boot start" in the registry"

    What is the disk driver? Could you direct me where the change needs to go for "boot start" in the registry?

    This would help me out tremendously. I have tried so many different things, and nothing has worked.

    (Slot 1) Apricorn Solo x2
    (Slot 2) Gigabyte R9 280x

    Appreciate your time, and advice.
     
  5. AidenShaw macrumors P6

    AidenShaw

    Joined:
    Feb 8, 2003
    Location:
    The Peninsula
    #5
    Installed:
    When Windows sees the new device, it may pop up a window saying "Installing device drivers" (if the driver is already on the system or in the driver cabinet (during installation a compressed file is left in the system area which contains common add-on drivers).

    It may also offer to search for a driver automatically, to see if the driver is available from the Microsoft download servers.

    If this fails, you'll need to contact Apricorn support or forums (or maybe look around MacRumours more) to get the driver and manually install it.

    Started:
    The Windows driver registry contains config values that specifiy which drivers to load an when. Relevant options are "boot time" (load during the BIOS phase), "automatic" (during normal OS initialization)​

    First step is to reconnect the Windows drive to the internal port, and boot with the Solo and a drive connected to the Solo. If Windows can see the drive, then the driver is configured. (Open "My Computer" -> "Manage" -> "Disk Management" to see the low-level disk configuration - a disk won't appear to File Explorer unless it's formatted with a valid partition table and file system recognized by Windows.)

    Once the drive is seen, open the "Device Manager" pane in "Manage". Expand the IDE, Storage and maybe SCSI tables (attached). Find the Apricorn Solo, get its properties, and expand the "Driver Details" section. The driver name is listed (sometimes several). (Picture attached for RocketRaid644LS - showing that the driver file is "rr640l.sys")

    Run regedit (the registry editor), and find HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\<drivername-without-sys>. There is key named "Start" - it should have the value 0. (Shown for RR644LS).

    You can find a lot of info on the web by Binging for "windows change ahci 0x0000007b" or "windows change 0x0000007b apricorn solo". From some of the latter links, it appears that you might have installed Windows with the drive in IDE mode, and the Solo uses AHCI mode - in which case the driver to start is "msahci".
     

    Attached Files:

    • dm1.jpg
      dm1.jpg
      File size:
      151.1 KB
      Views:
      40
    • dm2.jpg
      dm2.jpg
      File size:
      65.3 KB
      Views:
      40
    • dm3.jpg
      dm3.jpg
      File size:
      79.1 KB
      Views:
      36
  6. Gav Mack, Dec 7, 2014
    Last edited: Dec 7, 2014

    Gav Mack macrumors 68020

    Gav Mack

    Joined:
    Jun 15, 2008
    Location:
    Sagittarius A*
    #6
    The Apricorn cards show up as a standard AHCI controller in Windows device manager using the default ms achi driver. Though mine uses the Marvell 6G windows driver which Apricorn said wouldn't work - but does! And also off the second SATA port on the X2 via ODD power for the bootcamp SSD which they said wouldnt work either - but does too :D You can imagine that as a mixed Mac/Windows tech what I thought of the quality of their Windows boot camp support!

    If you guys having Windows boot problems and you are running a 3,1 they are a nightmare to boot Windows properly off the Solo X2. It is the EFI in that model which causes most of the grief booting into legacy mode seeing the Marvell BIOS boot rom and with twin cards you get similar problems apparently too also on the 4-5,1, presumably because of the twin Marvell BIOS boot roms in both cards conflicting with each other. Hence why I have stuck my second SSD on top of the first, run a single card and used its secondary port with a power extension and I got that setup working in my 3,1 and now transplanted into my 4,1.
     
  7. boodaddyz macrumors member

    boodaddyz

    Joined:
    Dec 25, 2008
    #7
    Thanks Aiden & Mav for the help with AHCI. I got AHCI finally working in Windows 8.1, and thought that would fix the "No boot drive detected" but it still comes up. The Solo x2 card driver, and AHCI is set to "value 0" PCIIDE is Set to "3"

    I am not sure if this is a Yosemite problem with EFI, and I should try Maverick or not, or if I should try installing Windows 8.1 in EFI mode.

    I even tried Refined Boot loader just to try something different, but that is doing the same thing. Apricorn support will not email, or call back.

    I can see the "Windows Bootcamp" drive/files when in OS X just fine, it's showing up as an external drive. I can even go into "Boot Options" and select Windows as the boot drive, but then the "No boot drive found" comes up. Works fine in Sata II

    This sucks lol :(
     

Share This Page