Cannot change Auto-Lock setting on iPhone4

THE dAY

macrumors 6502
Original poster
Jul 22, 2010
467
1
SFV California
iPhone 4 on 4.0.1 jailbroken

I have Auto-Lock set to 1 minute and tried to change to Never since I was going to use cyberduck and didn't want to keep waking up the phone.

Well the phone went to sleep after one minute and when I went into settings again to check it wouldn't load the page.

Had to respring the phone and setting was back to normal except Auto-Lock was set back to 1 minute.

I tried againg with same consequences.

BTW, i just updated to MobileSubstrate 0.9.3228-1

Can someone else check to see if they can change their Auto-lock time on their iPhone 4.

Thanks!
 

hoogen

macrumors regular
Jun 22, 2010
167
30
have you done a hard reset (hold power and home button untill the phone turns off, the turn phone back on)
 

scirica

macrumors 68020
May 13, 2008
2,068
1
Dallas, TX
iPhone 4 on 4.0.1 jailbroken

I have Auto-Lock set to 1 minute and tried to change to Never since I was going to use cyberduck and didn't want to keep waking up the phone.

Well the phone went to sleep after one minute and when I went into settings again to check it wouldn't load the page.

Had to respring the phone and setting was back to normal except Auto-Lock was set back to 1 minute.

I tried againg with same consequences.

BTW, i just updated to MobileSubstrate 0.9.3228-1

Can someone else check to see if they can change their Auto-lock time on their iPhone 4.

Thanks!
Do you have a corporate MS Exchange account on your phone? Just one thing that can affect that setting.
 

hoogen

macrumors regular
Jun 22, 2010
167
30
Do you have a corporate MS Exchange account on your phone? Just one thing that can affect that setting.
i was thinking the same thing but when you have a corporate ms exchange/some school emails, it takes away the "never auto lock" option completely, as in its not listed. im thinking its a glitch because of the fact that the page didnt load at one point. yet again it could be a bug on ios4 that we dont know of yet
 

hoogen

macrumors regular
Jun 22, 2010
167
30
Thank you all for the quick replies.

It seems as though the hard reset fixed the issue.

Thanks again!
glad i could help, a hard reset is a good thing to try whenever your phone is acting funny/unusual
 

zelaya

macrumors 6502
Jun 30, 2010
378
0
301
I've spend about an hour trying to figure out why I don't see the never option in the auto lock. I tried the hard reset and I was not lucky. I deleted my exchange email and I saw the "never" option again. I will have to install the exchange again and will have to deal with 5 minutes as my max..
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.