Cannot change permission status for Applications folder - error code 8076

Discussion in 'macOS' started by Caelum, Oct 16, 2008.

  1. Caelum macrumors newbie

    Joined:
    Dec 11, 2007
    Location:
    Australia
    #1
    Hi all,

    I'm running Leopard (10.5.5) on an Intel g5 iMac. I noticed this afternoon when trying to drop an app into my 'Applications' folder that I had to enter my password in order to do.

    Checking the 'Get info' pane for the folder I noticed that the permission status for 'everyone' was set to 'read only'. I have no idea how this happened but it must have been fairly recently as I was happily dropping apps into the folder only a few days ago.

    There are also two other 'names' in the panel labeled as 'unknown', one of whom has read & write permission and one of whom is also 'read only'.

    There are only two user accounts on my mac and we are both administrators, so I don't know why there are so many entries under the 'Sharing and Permissions' section.

    So anyway, I unlocked the panel with my password and tried to flip the permission for everyone from 'read only' to 'read & write'. I got the following error dialogue:

    "The operation could not be completed. An unexpected error has occurred. Error code - 8076."

    I tried to add a new 'administrators' group to the permissions panel with read and write access but received the same error.

    Any help would be greatly appreciated.

    Thanks.
     
  2. wh!plash macrumors member

    Joined:
    Mar 5, 2008
    Location:
    Sarasota, Fl
    #2
    Her'es an easy fix. Open the terminal, and enter
    Code:
    sudo chown -R myname:staff /Applications
    Replace "myname" with your login shortname though. If its asking you to authenticate, and you're the admin, its probably because you're not the owner of the folder anymore somehow. Once you're the owner, you can do whatever you want to it (set permissions as you choose).

    In my experience though, the permissions through the GUI are sketchy at best. To make it "stick" sometimes, you have to go through the terminal.

    If you're not familiar with this stuff, here's what it means:
    sudo = yes, i'm the admin. you can ask my password to make sure, but do what i say.
    chown = change ownership
    -R = Recursively. This folder, and everything under it.
     
  3. Caelum thread starter macrumors newbie

    Joined:
    Dec 11, 2007
    Location:
    Australia
    #3
    Thank you for the suggestion wh!plash, I've tried the command a few times but each time Terminal asks me for my password. I type it in, though nothing appears in Terminal when I do (I don't know if this is an error or if it is Terminal's way of 'blanking out' the password so that it cannot be read).

    Anyway, I type in the letters and press enter but the cursor just moves to the next line and nothing seems to happen. After rebooting, it doesn't seem to have changed anything.

    Just to make sure I am being clear: Finder asks me authenticate putting files into the Apps folder because I suddenly do not have write permission, only read. When I try to change my permission to read & write I get an error code.

    (I don't mean to suggest that you didn't understand, but I sometimes over-explain things and people are not sure what my problem is :eek: )
     
  4. pickyin macrumors newbie

    Joined:
    May 12, 2009
    #4
    Thanks, works for me to change the ownership of Users folder.
     
  5. Thornwalker macrumors newbie

    Joined:
    Feb 2, 2011
    #5
    >> Open the terminal, and enter

    How do I do that?
     
  6. Caelum thread starter macrumors newbie

    Joined:
    Dec 11, 2007
    Location:
    Australia
    #6
    Hi Thornwalker, I can't even remember how I solved this problem in the end, it was so long ago.

    But Terminal is located in Applications/Utilities. Open it up and it will give you a space to type in.
     

Share This Page