Cannot connect iMac & MBP to router at same time (internet hangs)

Discussion in 'Mac Basics and Help' started by kateeov, Jul 22, 2010.

  1. kateeov macrumors newbie

    Joined:
    Jul 22, 2010
    #1
    Hi

    Having a problem connecting the family's two Macs to our router at the same time. I've seen a few other threads that are similar, but none seem to be quite what's going on here....at least as far as I can tell.


    I have a MacBook Pro 4,1 running 10.5.8 with Airport Extreme. I primarily use Firefox but also a lot of Safari.
    My parents have an iMac 5,2 running 10.4.11 with Airport Extreme. They use Safari exclusively.

    Whenever both computers try to connect wirelessly to the Belkin Wireless G router, the internet hangs on both. Can't open anything. No spinning beach ball of death. Things just don't open. After 3 or 4 minutes the "Cannot load this page" comes up (not the "You are not connected to the internet" message).

    We've been having this problem for months (I bought them the router when I got my new MBP; this has been happening the whole time we've had them), but as I was only ever visiting for a few days, I just dealt with it & waited for them to go to bed before turning on my comp. Now that I'll be visiting for a few weeks, I'm trying to fix the problem.

    Unplugging the modem & plugging it back in will get things working for a few minutes, but then we soon end up back at nothing loading.


    Is this a router problem? Will a new/better router solve the problem?
    I have the exact same one at school and my housemates & I beat the tar out of it regularly without any problems - four girls streaming video/music, downloading, etc, all at the same time. But here at home If my father & I try to check email at the same time, everything freezes.
    Other computers connecting seems to not be a problem - my roommate had her laptop on her last visit and the two of us were able to get on together. But as soon as the iMac went on, everything stopped.

    Or is it in the computers themselves? Is there anything to be done if they just can't play nice together?


    Are we doomed to a summer of one computer at a time? Lol
    I don't mind forking over the money for a better router if that's actually the problem. I also don't mind poking around my computer a bit but I don't know a lot so if you can give me steps I'd really appreciate it (though Terminal scares me, so if there's any way around using it, I'd appreciate those first)
    If I can give any other info, just lmk. I'll be happy to. I just really want to be able to get online haha


    Thanks so much!
    Kate
     
  2. psxguru macrumors 6502a

    Joined:
    May 19, 2006
    #2
    Firstly, is the router set up to use DHCP?

    Are all the computers set up to use DHCP?
     
  3. kateeov thread starter macrumors newbie

    Joined:
    Jul 22, 2010
  4. psxguru macrumors 6502a

    Joined:
    May 19, 2006
    #4
    As a start I would switch everything off then...

    Turn on the cable/adsl modem on.

    Wait till all the lights show it has synced (depends on the make)

    Then switch on the router. Wait till that is fully synced.

    Then switch on one computer , wait till the airport has connected, then check you can browse the web ok.

    Then do the same for the other computer.

    If you get the same problem then check what IP addresses each mac has (system preferences | network) to make sure DHCP is working.
     
  5. snberk103 macrumors 603

    Joined:
    Oct 22, 2007
    Location:
    An Island in the Salish Sea
    #5
    What psxguru said, and.... when you check the IP addresses for both systems they should be different from each other. If you both computers are trying to use the same IP address problems will happen.

    I don't know that make of router, but on the Linksys one we use, in the setup screens, there is table of the IP addresses for the computers it thinks are connected. It is called the DHCP table. My very limited experience is that the entries there should match the IP addresses of the computers.
     

Share This Page