Cannot connect to app store on iPad 3

Discussion in 'iPad' started by fitzzzzzzz, Mar 25, 2012.

  1. fitzzzzzzz macrumors newbie

    Joined:
    Mar 23, 2012
    #1
    I can still search for apps and look at the "featured" apps but as soon as I try to look at the top 25 or "categories" section it sais "cannot connect to app store" . Weird huh? I already tried resetting and tried while connected to multiple different wifi sources with no luck. Anybody know what's going on?
     
  2. BigB117 macrumors member

    Joined:
    Mar 16, 2012
    #2
    Wirelessly posted

    I had the same problem yesterday and changing my apple id password fixed it.
     
  3. fitzzzzzzz thread starter macrumors newbie

    Joined:
    Mar 23, 2012
    #3
    Thanks for the suggestion. Unfortunately it didnt work for me. The app store works fine on my iphone. I dont know what could be causing this
     
  4. djrod macrumors 65816

    djrod

    Joined:
    Sep 16, 2008
    Location:
    Madrid - Spain
    #4
    I couldn't download any app yesterday, not with my iPhone, not with my iPad. Maybe they are changing something?
     

Share This Page