Cannot connect to external HDD with El Capitan

Discussion in 'OS X El Capitan (10.11)' started by vyvafc, Dec 12, 2015.

  1. vyvafc macrumors newbie

    Joined:
    Nov 21, 2015
    #1
    I have a mid-2011 iMac. I have just installed El Capitan, having been running Mavericks.

    A few weeks ago I purchased a Seagate Personal Cloud external HDD and set it up - it worked fine. But since installing El Capitan, I cannot access it.

    Specifically:

    - In Finder, the drive appears in Shared/All section, but has a question mark next to it.
    - If I click on the drive in Shared/All, it says 'Connection Failed', and if I click on 'Connect As' a window appears stating, 'There was a problem connecting to the server "Personal Cloud": the server may not exist or it is unavailable at this time. Check the server name or IP address, check your network connection, and then try again'.

    The set-up is that the Seagate drive is connected by ethernet to an Apple Time Capsule, which is my wireless router.

    The Seagate drive appears and works without problems on my Samsung TV and iPad, so I know the drive is ok.

    I read some other threads about this and it was suggested to update the Seagate drive (Paragon driver) - I did this but not it didn't change anything. I couldn't find any other solution.

    I tried restarting the Time Capsule, and this actually resulted in my being able to see the folders on the Seagate drive on Finder - but as soon as i clicked on them the drive became unavailable again.

    Any advice most welcome - with thanks
     
  2. vyvafc thread starter macrumors newbie

    Joined:
    Nov 21, 2015
    #2
    Forgot to say: external drive does not appear in Disk Utility
     

Share This Page