Cannot connect to internet via ethernet or wireless

Discussion in 'Mac Basics and Help' started by rexual, Oct 1, 2009.

  1. rexual macrumors newbie

    Joined:
    Oct 1, 2009
    #1
    Hi,

    I'm brand new to Mac. I just got a MacBook Pro, and I've been having some troubles connecting to the internet at home. I have a LinkSys WRT54GS router with Firmware Version: v1.50.9. I'm unable to access the internet through both ethernet and wireless. Concerning wireless, I have tried connecting using WEP, and have tried entering passcodes both with and without an "$" and "0x" preceding the 10 digit WEP passcode. I have also tried switching the encryption over to WPA2, and still nothing. I have even disabled the security to see if it's able to connect -- it's not.

    I had some error regarding not being able to find it's IP or something along those lines.

    Does anyone have any idea what I'm doing wrong?

    Thanks
     
  2. Xapphire13 macrumors regular

    Xapphire13

    Joined:
    Jan 14, 2009
    Location:
    South Australia
  3. rexual thread starter macrumors newbie

    Joined:
    Oct 1, 2009
    #3
    Yeah, it is.

    Still can't figure out what's going on. Went to a public wifi spot and i was able to connect without a problem, so everything seems good on that front. I've messed around with assigning the IP manually, but still nothing. Any advice?
     
  4. mkrishnan Moderator emeritus

    mkrishnan

    Joined:
    Jan 9, 2004
    Location:
    Grand Rapids, MI, USA
    #4
    What is the rest of the network configuration -- what sits on the other side of the Linksys, and what else connects to the Linksys (and how = wired or wireless)?

    Couple of obvious ones that come to mind...

    - Your Linksys has MAC filtering and you haven't added the MBP to the MAC list.
    - You have another computer that is ignoring DHCP and grabbing an IP in the DHCP range and screwing up distribution for the rest of the computers
    - Or else there is some other minor router configuration issue that could probably be solved by just power cycling the router.
     
  5. rexual thread starter macrumors newbie

    Joined:
    Oct 1, 2009
    #5
    I've got a Comcast issued Motorola Surfboard modem. We've got up to 3 laptops connecting at a time, all PCs which can access the network without a problem. On the MBP, Airport greenlights and says Connected if I manually assign an IP, but I'm not able to access the internet. If I just have it go DHCP it says No IP Address.

    I checked the network settings, MAC filtering is definitely disabled. I also turned off all computers minus the MBP and still no luck, and I power cycled the router and modem and still no luck.
     

Share This Page