Resolved Cannot connect to iTunes Store

Discussion in 'iOS Apps' started by Floris, Jan 31, 2016.

  1. Floris macrumors 68020

    Floris

    Joined:
    Sep 7, 2007
    Location:
    Netherlands
    #1
    for the last few days i cannot buy any apps and i do not know how to figure this out

    I can open the app
    I can refresh it with touching menu ten x and see it refresh
    I can find apps
    I can download free apps

    But paid apps. I click buy. Enter the oass (which is correct) and it cycles and then error pops up saying it cannot connect to iTunes store. To try again. Trying again has the same result.

    I tried wifi at home on iPhone
    I tried 4g at home on iPad
    i tried wifi on iPad at parents (diff location)
    And I tried 4g at a different location on the iPhone.

    Not sure what to do next. I googled and checked this forum as well as twitter. But i see no recent entries of other (Dutch) people reporting this.

    I hope you guys can give me some tips before I have to go and call Apple on Monday.
    image.png
     
  2. Goatllama macrumors 6502a

    Goatllama

    Joined:
    Jun 24, 2015
    Location:
    Mountaintop Lair
    #2
    Have you signed out and back in to your Apple ID?
     
  3. Floris thread starter macrumors 68020

    Floris

    Joined:
    Sep 7, 2007
    Location:
    Netherlands
    #3
    That gave an error as well. Could not login to iTunes store. Unable to connect.

    Geekfix contscted me with a link. They said it fixed it for them to force restart their iPad with holding home and sleep. I did that. And it is fixed on the iPad. I restarted the iPad yesterday when I tried the new public beta (phone runs on 9.2.1 stable). But i have no idea why a forced restart like that helps. It seems fixed on iPad. At least i could get the apps now.
     
  4. Floris thread starter macrumors 68020

    Floris

    Joined:
    Sep 7, 2007
    Location:
    Netherlands
    #4
    Update, it's resolved. The forced reboot is the only thing that fixes it (for some reason). Normal shutdown and restart didn't help on the iPhone either. But, it's working now. Thanks for those who PM me some links to solutions.
     

Share This Page