Cannot connect to SMB share on one Mac

Discussion in 'iMac' started by wernerdev, Apr 7, 2011.

  1. wernerdev, Apr 7, 2011
    Last edited: Apr 7, 2011

    wernerdev macrumors newbie

    Sep 8, 2010

    I have a very strange problem. I have 3 Macs. All worked fine with SMB shares. Until a few days ago. My newest iMac won't connect to my SMB server share anymore.

    It shows up in the Finder Shared section. When I try to connect it just keeps "Connecting...". When I press "Connect As..." it does show the login window, but when I fill in my login info and press Connect it just freezes the Finder window. It becomes totally unresponsive and get's drawn improperly. I will have to restart Finder using "killall Finder" using the Terminal.

    If I try to navigate to the Network section in Finder, it just freezes again. I will have to reboot my iMac to acces the Network section again.

    When trying to connect to the server manually using "smb://" it says: There was an error connecting to the server. Check the server name or IP address and try again. If you are unable to resolve the problem contact your system administrator.
    But I can ping the server using the Terminal, so the connections are not blocked completely.

    First I suspected the server. So I tried connecting to it using my other Macs. It worked perfectly on those. So it's clearly some problem on that iMac.
    Workgroups are all the same.

    Is there some way to reset the iMac's sharing settings? Does it keep a cache or something?
    I cleaned the Mac using Onyx and CleanMyMac. But nothing helped.

    Also searched the internet on similar problems, but nothing exactly like this.
    I hope someone can help me.
  2. wernerdev thread starter macrumors newbie

    Sep 8, 2010
    This topic can be deleted/closed. I see I have posted it in the wrong category.

Share This Page