Cannot connect to specific wireless router (10.5.2)

Discussion in 'macOS' started by theprizefight, Mar 9, 2008.

  1. theprizefight macrumors member

    Joined:
    Oct 29, 2006
    #1
    I think this has been an issue since I updated to 10.5.2 but not positive.

    I have a router that was working fine for several months before I had any problems. I could connect to it and configure it via 192.168.0.1 whenever needed.

    It worked fine with the retail release of leopard, but since I updated to 10.5.2 Im having a big problem. I can see the network in my Airport list, and when I click on it I get a perfect 4 bar connection. However, I cant access any web pages, Adium wont connect, no torrents, nothing.. nor can I get into the router IP itself.

    I have roommates who can connect to it with no problem, 3 windows laptops, and one Macbook with 10.5.2

    Also, if I get into the router configuration through a roommates computer, while my macbook pro is supposedly connected to the network, the router sees my computer as an active client.

    Anyone know what might be the issue? Why is it saying Im connected when im not?
     
  2. Cerebrus' Maw macrumors 6502

    Joined:
    Mar 9, 2008
    Location:
    Brisbane, Australia
    #2
    Do you get a good ip4 address? Im assuming you are, since you are being shown logged on the network. It should be something along the lines of 192.168.0.2/3...

    Also, what type of security is on the router?

    If you want, try this step:

    -Close all applications
    -Goto MacintoshHD/Library/Preferences and look for a folder called System Configuration. The folder should have about 6-8 .plist files.
    -Drag this folder to the desktop.

    Reboot your computer, and try connecting to your router.

    Please note, this will reset a lot of wireless (EG: bluetooth/ SMB ) settings, so you may have to go through some setups as you use your computer in the future. If your not comfortable with this, try specific .plist files within the System Configuration folder, namely the networksettings.plist
     
  3. theprizefight thread starter macrumors member

    Joined:
    Oct 29, 2006
    #3
    I did what you suggested, still doesnt work.

    I get an IP address.

    It is WPA encryption.
     
  4. HawaiiMacAddict macrumors 6502a

    Joined:
    Dec 28, 2006
    Location:
    On one of my Macs of course
    #4
    Aloha theprizefight,

    Go into System Preferences -> Network, highlight your Ethernet connection on the left, then click the Advanced... button. When the next cascading property sheet drops down, click on the Renew DHCP Lease button. Renewing your DHCP lease should only take a couple of seconds, so if you're waiting for at least 20 seconds, you know there's a problem with communication between your router and the NIC in your computer. If successful, you should see your IP address, your subnet mask, and the IP address of your router. Pull up a terminal and try to ping your router (if you're seeing the IP address, you will be able to ping it) to verify a good connection.

    The next thing you should probably try is removing, only temporarily, the WPA encryption from your wireless AP. I've noticed that WinXP clients have sporadic problems with WPA2, but my Mac clients have absolutely no problems there. You should do this in steps - first try with no encryption, then try WEP, then try WPA, then try WPA2 if you want that level of encryption on your network. You can also try the 'traceroute' command in your terminal. Just type 'traceroute www.apple.com' for example (without the single quote marks), and it will trace the route between your computer and apple.com, in this case, over a maximum of 64 hops using 40 byte packets.

    Check your router from one of your friend's computers and verify that your DHCP IP pool is large enough - you could also reset your router/cable modem as well. That way you can force a renewal of the DHCP assignment from your ISP to your cable modem/router.

    I know that wireless issues can reach the point where you want to pull out your hair, but try those steps and see if you can reach a definite point of failure. That way we can better assist you.

    HawaiiMacAddict
     
  5. theprizefight thread starter macrumors member

    Joined:
    Oct 29, 2006
    #5
    I have renewed DHCP many times, both from my mac and within the router. No luck.

    I tried changing security settings, off, WEP, WPA-personal. WPA enterprise. No luck.

    I can only ping the router when Im connected via ethernet cable to the router.

    IP pool is plenty large.

    Have reset router/cable modem many times. no luck.
     

Share This Page