Cannot connect to Udemy.com website

Discussion in 'macOS Sierra (10.12)' started by Rob.G, Oct 13, 2016.

  1. Rob.G macrumors 6502

    Rob.G

    Joined:
    Jan 17, 2010
    Location:
    NW Oregon
    #1
    Yeah it sounds weird, but it's true. It was working fine until today. I went back to the browser tab (Safari) that I had kept open, and was watching a couple of videos of a course I had recently purchased. Then it stopped responding. I closed the tab, reopened, and from that point forward, I cannot connect. Safari says it can't establish a secure (https) connection, period. I tried Chrome. It says the certificate has been revoked. Opera says the same thing. However... I just now tried Firefox to cover all my bases and IT WORKS. What the ????

    Now, it worked fine at work on my PC. It worked fine on my Windows server (via RDP). It worked fine on my phone. But not on Safari, Chrome or Opera on my Mac. And it does work on Firefox.

    I've done networking and web stuff for twenty years and I'm not even sure where to start with this. This is the kind of crap I expect from Windows, not from my Mac.

    Thoughts? :)

    Rob
     
  2. twentworth12 macrumors newbie

    Joined:
    Nov 24, 2008
    #2
    It's a problem with a root certificate provider who revoked their own certificate that is affecting lots of sites today. The problem has been fixed, but will take some time to propagate through all the cache servers.
     
  3. fisherking macrumors 603

    fisherking

    Joined:
    Jul 16, 2010
    Location:
    ny somewhere
    #3
    odd stuff. the site seems fine here in both safari and chrome. but the problems you're experiencing in those 2 browsers are what i'm experiencing on soundcloud.com and musicgateway.net (i started a thread on this).

    seems... highly inconsistent. can you try the 2 sites i can't get into? trying to figure the common denominator...
    --- Post Merged, Oct 13, 2016 ---
    ah, interesting. just so random (for example, one of my macs can open a site the other can't; same os etc)...
     

Share This Page