Cannot connect to wifi!

Discussion in 'MacBook' started by rcarranza, May 23, 2010.

  1. rcarranza macrumors member

    Joined:
    Feb 9, 2009
    Location:
    Edinburgh, Scotland
    #1
    Hey guys,

    I've done a little digging and cannot find an answer to this problem.

    I have a Macbook circa November 2008 and a Netgear WNR854T Router.

    I try to connect to my wireless network but my Macbook won't do it. It will list my network in the network list and will connect to other unsecured networks but not to mine. I use WPA2 security on the network.

    Alternatively, my Macbook Air, Mac Mini, iPhone, iPod Touch, Blackberry, Xbox 360, PS3 and Wii have no problems connecting.

    There is no MAC filter enabled on the router.

    Any ideas?
     
  2. mrsir2009 macrumors 604

    mrsir2009

    Joined:
    Sep 17, 2009
    Location:
    Melbourne, Australia
    #2
    Have you tried resetting the Router and your MacBook's Airport system?
     
  3. rcarranza thread starter macrumors member

    Joined:
    Feb 9, 2009
    Location:
    Edinburgh, Scotland
    #3
    Yeah.

    My network appears in the list and when I try to select it the Macbook tries to connect but just times out.
     
  4. mrsir2009 macrumors 604

    mrsir2009

    Joined:
    Sep 17, 2009
    Location:
    Melbourne, Australia
    #4
    Hmm. Disconnect EVERYTHING from the network, all your other computers, PS3, Xbox etc. Then try connecting your Macbook. It may be an overload or somethin'
     
  5. BBC B 32k macrumors 6502

    Joined:
    Aug 5, 2005
    Location:
    London
    #5
    Same issue here. Have re installed Snow Leo, removed and re fitted the airport card, re booted the router a thousand times. Weird thing is my work C2duo MacBook is fine but my own c2duo MacBook is nothing but trouble.

    HELP :eek:
     

Share This Page