"Cannot Connect to YouTube"

Discussion in 'Jailbreaks and iOS Hacks' started by groovs, Oct 17, 2009.

  1. groovs macrumors member

    Joined:
    Aug 12, 2009
    #1
    iPhone 3.0 Jb (redsnow) and Unlocked (ultrasnow)
    Everythign seems to be workign fine except for Youtube app on Edge.

    On edge all my mails, safari, facebook and all other apps are working but when on youtube app it says cannot connect to youtube .... ANy ideas ???? Strangely if i open youtube on safari while on edge ..it works ..:confused:

    While on WiFi all works good even Youtube app works ......

    no idea i am very confused ......
     
  2. dhlizard macrumors G4

    dhlizard

    Joined:
    Mar 16, 2009
    Location:
    The Jailbreak Community
    #2
    I don't think you tube will work on Edge, it's too slow.

    Have no idea why it works thru Safari on Edge.

    Likely the You Tube app has it restricted

    Less than 10 seconds on Google .....:rolleyes:

    http://modmyi.com/forums/native-iphone-ipod-touch-app-discussion/5928-trick-use-youtube-edge-network.html
     
  3. groovs thread starter macrumors member

    Joined:
    Aug 12, 2009
    #3
    well it was working on Edge before ...... i dont get the reason why not now ....:eek:
     
  4. groovs thread starter macrumors member

    Joined:
    Aug 12, 2009
  5. funkscott macrumors newbie

    Joined:
    Oct 4, 2009
    #5
    well i have a unlocked iphone n my you tube dont work on 3g, was working then one day stopped, works fine on wifi, dont know if its down to being unlocked n running on uk vodafone?
     
  6. groovs thread starter macrumors member

    Joined:
    Aug 12, 2009
    #6


    Any one having the same problem ... I have iphone 3g ... youtube was working fine on Edge and on fine day it stopped working ...still works on Wifi though ...
     
  7. con500 macrumors regular

    Joined:
    May 9, 2009
    #7
    Same here...thing is when i was on 2.2.1 youtube worked fine over edge.

    Then i upgraded to 3.0 and youtube stopped working however i just ignored it thinking it would be adressed in a future F/W upgrade

    last week i upgraded to 3.1.2 and STILL youtube doesnt work :confused:
    (works over wifi)

    f/w 2.2.1 rocks...i would go back but a lot off my apps are dependant on my upgrade :cool:
     
  8. groovs thread starter macrumors member

    Joined:
    Aug 12, 2009
    #8
    i wish it was easy ......

    i have tried everything and i mean EVERYTHING ... :( .... doesnt work .... apprently nothing seems wrong ...and all the settings are in the right place

    anybody with any ideas ? ??

    -i have tried changing / updating carrier files.
    - turning push on and off
    - removing emails settings
    - restoring
    - Setting up as new phone
    - removing all apps
    - puttign in DFU ...

    :(
     
  9. fsck-y dingo macrumors 65816

    fsck-y dingo

    Joined:
    Jun 14, 2009
    #9
    That's strange. It should connect using the edge network. I just tried on my 3G with 3.1.2 firmware and it worked for me. Have you tried MxTube from Cydia? It's almost the same thing and you can save the videos to your phone. I know that doesn't fix your problem but it may be an alternative for now.
     
  10. polobreaka macrumors 6502a

    Joined:
    Aug 10, 2009
    Location:
    Huntington Beach, CA
    #10
    i thought the youtube app is restricted?

    what if you download 3g unrestrictor from cydia? you have to pay though.
     
  11. mkrishnan Moderator emeritus

    mkrishnan

    Joined:
    Jan 9, 2004
    Location:
    Grand Rapids, MI, USA
    #11
    With 3.0 you had to do some funny tricks to get a hacktivated phone to run Youtube. It seems like the 3.1+ version of Pwnage tool takes care of this automatically -- sadly, I put 3.1 on my phone like the day before the 3.1.2 update for Pwnage came out, and I still haven't gotten around to doing 3.1.2, but with 3.1, Youtube worked without having to do anything funny.

    Anyway also there was another thread today where it seemed that putting the Youtube app in a category caused strange behavior, but it seemed like the opposite of what you guys are describing.
     
  12. groovs thread starter macrumors member

    Joined:
    Aug 12, 2009
    #12
    well i tried this ...somehow now youtube on Edge is workign fine ...:confused:

    go to this location on your iphone ... (i used iPhone browser)

    /private/var/root/lockdown

    delete everything in lockdown folder including the subfolder

    Turn off you iphone. Turn on itunes on your PC / MAC then turn on you phone ... that was all ... it was working fine after that ......
     
  13. groovs thread starter macrumors member

    Joined:
    Aug 12, 2009
    #13
    did this work out for anyone else ???
     
  14. greomoto macrumors newbie

    Joined:
    Dec 1, 2009
    #14
    Same Here

    I work with a guy that sits right next to me in the office and he has one of the original IPhones. We are both using the Edge network. Neither myself or another guy in the office can connect to YouTube. (Both with Iphone 3GS).

    Anybody got any ideas???:mad:
     
  15. mkrishnan Moderator emeritus

    mkrishnan

    Joined:
    Jan 9, 2004
    Location:
    Grand Rapids, MI, USA
    #15
    FWIW, the issue seems to be automatically corrected without needing any additional hacks with the pwnage tool 3.1+ firmwares...
     
  16. Gix1k macrumors 68030

    Gix1k

    Joined:
    Jun 16, 2008
  17. Frankgt13 macrumors newbie

    Joined:
    Dec 29, 2009
    #17
    Download mxtube from cydia it's YouTube but better
     
  18. Leet Apple macrumors 6502a

    Leet Apple

    Joined:
    Nov 10, 2009
    Location:
    Canada
  19. swoosh0217 macrumors 6502a

    swoosh0217

    Joined:
    Nov 20, 2007
    Location:
    NW
    #19
    This is the source

    Add this to your source in Cydia and download Push for youtube and it should fix it: http://apt.macosmovil.com/
     
  20. faroZ06 macrumors 68040

    faroZ06

    Joined:
    Apr 3, 2009
    #20
    Cannot connect to Youtube

    On my iPhone 2G with 3.1.2 (jailbroken), Youtube does NOT work over WiFi, and I don't have a SIM card. It just says "Cannot connect to Youtube". The fixes online all told me to add a repository, but the URLs were either bad or Cydia froze when I did it.
     

Share This Page