Cannot Copy File as File is in Use (Mac to Network Drive)

Discussion in 'OS X Yosemite (10.10)' started by tdale, Feb 7, 2015.

  1. tdale macrumors 65816

    Joined:
    Aug 11, 2013
    Location:
    Christchurch, N.Z.
    #1
    Another poster wishes to help with this so creating a new thread.

    Copying over wifi from Mavericks onwards to a network drive, causes this error. Maybe first time, maybe it takes 4 times to copy, intermittent.

    Suggestions online don't work, but they may do, then doesn't. Suggestions have been:
    -Turn off icon preview and preview pane
    -Use Terminal to switch to SMB1 or CIFS
    -Right click the file, not fully select it when copying
    -I used to copy, then select and unrelated file so as to not have the file I want to copy as being selected, that seemed to work,now its playing up.

    My resolution was to put the file into a folder, and copy the folder, but as Graham wants to discuss, he may have other solutions, or reasons.
     
  2. grahamperrin, Feb 8, 2015
    Last edited: Feb 8, 2015

    grahamperrin macrumors 601

    grahamperrin

    Joined:
    Jun 8, 2007
    #2
    Problems with SMB service from WD TV: first look

    Thanks. For other readers, some additional context:

    I'll take a closer look later – I have a few things in browser history that might be useful. Incidentally I shouldn't treat this as specific to Yosemite.

    tdale, have you tried BlueHarvest? (Just curious – it's too soon to suggest the product as a workaround to the problems in your case. It's preferable to not intentionally discard metadata.)

    To clarify: that's client side, yes?

    Related

    WD TV Live

    WD TV | Media Player

    Why are dot underscore ._ files created, and how can I avoid them? – answers include Purposes of .DS_Store and ._ files

    "… File business during a copy by Finder …"​
     
  3. tdale, Feb 8, 2015
    Last edited by a moderator: Feb 11, 2015

    tdale thread starter macrumors 65816

    Joined:
    Aug 11, 2013
    Location:
    Christchurch, N.Z.
    #3
    Hi Graham, and no, haven't tried that, but I don't follow the connection.
     
  4. grahamperrin macrumors 601

    grahamperrin

    Joined:
    Jun 8, 2007
    #4
    Symptom of a problem with file service (not with OS X)

    One of the things that you mentioned earlier –

    "… file in a folder if its not already in one, and copy the folder …"​

    – is recognisable as a client-side workaround for some types of poorly designed file service; servers that do not have good support for the metadata that may be beneficial, sometimes essential in a Mac environment.

    For that reason my instinct is to focus primarily on the Western Digital firmware/software.

    I don't expect an opportunity to test with any type of WD TV hardware, and detailed testing can be unexpectedly time-consuming, but there's a fairly simple way of testing the Western Digital environment.

    For a moment, ignore folders.

    If a file that can not be copied using Finder can be copied using ditto(1) with its --norsrc option, then I would say that there's a problem with Western Digital support for OS X.
     
  5. tdale thread starter macrumors 65816

    Joined:
    Aug 11, 2013
    Location:
    Christchurch, N.Z.
    #5
    When I researched this, the many others with the same issue had varying drives, and devices, I can only recall me using a WDTV and drive actually. However, the behaviours were all the same no matter what drive or device was in use, it comes back to an SMB1/2 network issue it appears.

    Note that I can copy files using Finder to me network drive. It may work first time, or second, or third, or fourth, which in itself is bizarre
     

Share This Page