cannot copy from usb stick to iMac G4 HDD OSX 10.4.11

Discussion in 'PowerPC Macs' started by retroformat, Feb 26, 2015.

  1. retroformat macrumors newbie

    Joined:
    Feb 26, 2015
    Location:
    toddler mayhem
    #1
    For some years I've been using this USB stick to move files to and from my G4 iMac (running OSX Tiger v.11). Suddenly today, the iMac has stopped allowing moving (copying) files from the usb stick to _anywhere_ on the HDD.

    So far as I can tell nothing has changed in my usual routine. The usb stick has not been to any unusual locations - it shuttles just between three macs that I have, and none of the other macs are having a problem with it.

    The USB stick mounts fine in the iMac G4, I can copy files TO the usb stick. But I cannot drag any file from the USB stick to any folder, nor the desktop, nor the HDD icon, etc. I've rebooted the iMac, and it is still misbehaving.

    I've checked the read/write permissions on the HDD and various folders, with no issues apparent. I've also used the Disk Utility to "fix permissions" on the HDD volume. No joy. I'm stumped!

    Any additional tips would be greatly appreciated!

    I tried searching for this problem on google and on this forum, but get lots of irrelevant hits with keywords "copy, USB, Tiger, etc." so I apologize if this problem has been discussed before.
     
  2. weckart macrumors 68040

    Joined:
    Nov 7, 2004
    #2
    It really does sound like a permissions issue. Have you tried copying from any other media to HDD?
     
  3. retroformat thread starter macrumors newbie

    Joined:
    Feb 26, 2015
    Location:
    toddler mayhem
    #3
    Not any other "media" (i.e. could try another USB stick or a CD-rom, haven't done that yet). I do have the machine on a network / LAN, and can successfully copy files to it from both a PM8500/300 (running OS8) and an iBook running OSX Leopard. Not sure if that's relevant to permissions. (In fact I'm tempted to start a thread on just permissions, because those are -constantly- getting in the way of other things I like to do).

    (So I've used a workaround, by putting the USB stick into the iBook, copying files to iBook, and then copying from iBook to iMac over the LAN. But I'd still like to figure out and fix this problem with the G4 iMac).
     
  4. vlark, Feb 26, 2015
    Last edited: Feb 27, 2015

    vlark macrumors member

    Joined:
    Mar 13, 2014
    #4
    I've had this happen to me. It was the USB stick going bad. You've said you've been doing this sneaker-net system of moving files to the Mac from this particular USB stick for awhile; it seems the flash memory on the stick has finally reaced it's end of life. Time to get a new USB stick, perhaps.
     
  5. DeltaMac macrumors 604

    DeltaMac

    Joined:
    Jul 30, 2003
    Location:
    Delaware
    #5
    Try a different USB stick.

    If you only need to copy text files - you can find 4GB sticks for under $5.
     

Share This Page