Cannot delete a file from external hard drive

Discussion in 'OS X Mavericks (10.9)' started by pletsch, Sep 26, 2014.

  1. pletsch macrumors newbie

    Joined:
    Nov 7, 2012
    #1
    I have 2 files that i want to delete from my hard drive. Every time i delete them, and send them to trash, and try to empty the trash (normally or secure) it makes the sound of deleting, but the files remain.

    From what I understand from my digging is that my computer thinks they may be system files and won't delete them.

    I've tried to use the terminal actions (ie. sudo rm -rf /Volumes ) but it gives me the response of "directory not empty"

    My permissions for the external drive are "read and write"

    The folders are both empty from what I can see.

    I can't see "ghost files" as I don't have access to a windows computer.

    Format for the external is FAT 32

    I know its not a huge deal but still very frustrating.

    Thanks for any help
     
  2. Big Ron macrumors 6502

    Big Ron

    Joined:
    Dec 7, 2012
    Location:
    United Kingdom
    #2
    I had a problem similiar to yours when I tried to use an older drive that I used to use for Windows Backup. The first method is simply to get someone with a PC to remove them - failing that -

    My preferred method, probably not the most efficient but most effective was to:

    Remove all the files of the drive that I wanted to keep.
    Format the drive as NTFS
    Format the drive as FAT 32

    I agree its a bruit force approach but it works: Simply copy back what you want.:cool:
     

Share This Page