cannot delete files on 10.7.5

Discussion in 'Mac OS X Lion (10.7)' started by serifstelar, Jan 24, 2013.

  1. serifstelar macrumors newbie

    May 31, 2012
    Hi everybody!

    Every time i'm trying to delete a folder or a file, finder prompts for my user password and the file/folder disappears but it doesn't go in trash and the space is not freed up from the hd.
    I tried with verify/repair disk permissions but it didn't help.
    I didn't make any changes before this, everything worked normal.
  2. GGJstudios macrumors Westmere


    May 16, 2008
  3. serifstelar thread starter macrumors newbie

    May 31, 2012

    fixed with this:

    1. Reboot the computer.
    2. Login with the troubled user account
    3. Open 'Terminal'
    4. Type:

    sudo rm -frv ~/.Trash

    Note: This removes the old ".Trash" directory and all files and folders in it.

    3. Type:

    mkdir -v ~/.Trash

    Note: This creates a new ".Trash" directory in your home folder.

    4. Type:

    killall Finder

    Note: This kills/restarts Finder

    5. Close Terminal.

    6. Reboot Computer.

    Thank you!

Share This Page