Cannot delete folder in use--please help

Discussion in 'macOS' started by yanksphish, Nov 17, 2009.

  1. yanksphish macrumors newbie

    Joined:
    Nov 17, 2009
    #1
    I have 2 folders on an external HD attached to my airport extreme that I cannot delete. When I try to delete them it says they are in use. They both look empty. I'm not familiar with terminal, but I've tried a few different commands I've found on these forums. I've tried sudo rm -rt and similar commands and they all say the directory is not empty. Any ideas on how to delete these folders will be very nice.

    Thanks
    Joe
     
  2. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #2
    Try closing some applications, such as Preview or any other you've used on files on that drive. Then try deleting the folders.
     
  3. yanksphish thread starter macrumors newbie

    Joined:
    Nov 17, 2009
    #3
    i get the same message saying the directory is not empty. I'm not sure why it won't delete it. I don't have any programs running.
     
  4. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #4
    Did you reboot? Rebooting cures a lot of things.
     
  5. Gregg2 macrumors 603

    Joined:
    May 22, 2008
    Location:
    Milwaukee, WI
    #5
    Can you change the name of the folder before you put it in the Trash? Give that a try.
     
  6. ViViDboarder macrumors 68040

    ViViDboarder

    Joined:
    Jun 25, 2008
    Location:
    USA
    #6
    Instead of rebooting you can usually just logout.

    There are also other ways to see what process is actually using the drive. I don't remember them though. Something from the command line using 'lsof' I think.
     
  7. Jason Beck macrumors 68000

    Jason Beck

    Joined:
    Oct 19, 2009
    Location:
    Cedar City, Utah
    #7
    Yah it happens once in a while, even on windows, just logout and login.
     
  8. drag0nfly macrumors newbie

    Joined:
    Jun 18, 2011
    #8
    same problem; but none of previous solutions works

    So, I have an - apparently - empty [directoryname1]/[directoryname2] sitting on my storage raid. no files n either directory. double checked using xray. nada. Neither directory is locked; I have gone in using finder and term window; have verified permissions and ownership; I am admin.


    i cannot delete [directoryname1]/[directoryname2] or cd into [directoryname1] and just delete [directoryname2]

    However! I can change the names of either directory without the system fussing at me.

    in all cases, I am told forbidden to delete tho cause they are "in-use" I have no apps running on them, rebooted, etc....I have specifically ran NORTON against them to look for a bit of clever hack code. If it is there, it is more clever than Norton, which was verified updated yesterday.

    completely, utterly frustrated and stumped.
     
  9. sridvijay macrumors newbie

    Joined:
    Mar 9, 2010
  10. liljake119 macrumors newbie

    Joined:
    Oct 30, 2013
    #10
    Same problem. Weird circumstances

    I am trying to delete a folder from my Macbook Pro with retina 13 running 10.8. Its just a normal user created folder. It has no contents (none hidden either) and I cannot change the name of the folder, but I can rename its parent directory. I have tried the above solutions with no luck. I even upgraded to Mavericks and it still tells me the folder is in use.

    Any ideas?
     

Share This Page