Cannot Delete Microsoft Office

Discussion in 'OS X Mavericks (10.9)' started by Mobster1983, Nov 9, 2013.

  1. Mobster1983 macrumors 6502

    Joined:
    Sep 8, 2011
    #1
    One of the reasons I truly hate Microsoft, their crap is so difficult to get rid of.

    I am running Mavericks, and got tired of Microsoft Office 2008 and its "quirks." I tried to delete it using the uninstaller and got the message "You don't have permissions to perform this action." I got the same message when I just tried to move the entire Microsoft Office folder to the trash.

    I am on my primary admin account. Also, I went to the "Get Info" screen and the lock icon at the base will not change from locked after clicking on it. I did get a new iMac (late 2013) and transferred the user accounts. I cannot figure out how to force delete this folder.
     
  2. LV426 macrumors 6502a

    Joined:
    Jan 22, 2013
    #3
  3. rocknblogger macrumors 68020

    rocknblogger

    Joined:
    Apr 2, 2011
    Location:
    New Jersey
    #4
    Not defending MS or Office but that's a very thorough article on the process. And if you've ever perused all those different folders that they tell you to go to so that you can delete everything, you'll see crap left over from different apps you may have installed and removed over the years.

    While a lot of apps are good at removing themselves when you drag to the trash or use there uninstaller apps, a lot also leave a lot of small crap behind. I do agree though that in this specific case the uninstall process was poorly implemented (as well as the install process I suppose) and there are too many steps that one has to go through.
     
  4. maflynn Moderator

    maflynn

    Staff Member

    Joined:
    May 3, 2009
    Location:
    Boston
    #5
    There are many apps including that require an uninstalled. I think apple's aperture is the same. Adobe also requires an uninstaller. The complexity of apps require this
     
  5. roadbloc macrumors G3

    roadbloc

    Joined:
    Aug 24, 2009
    Location:
    UK
    #6
    You can just drag it to the trashcan if you wish, but a lot of extra library and preference files will be left behind. Just like any other app really. It's nice that not only does Microsoft include an uninstaller but also have a detailed article on how you can totally de-office-ify your Mac.
     
  6. LV426 macrumors 6502a

    Joined:
    Jan 22, 2013
    #7
    One reason I prefer to purchase apps from the App Store, where the recommended removal procedure is click and hold the icon until a delete cross appears.
     
  7. Mobster1983 thread starter macrumors 6502

    Joined:
    Sep 8, 2011
    #8
    Thanks, but I read that and tried it long before posting here. Didn't work. I keep getting "You don't have permission to perform this action."

    I am guessing the issue stems from when I transferred MS office from my MacBook Air to my new iMac. Nothing else in the user account is having issues though.

    Hopefully someone can help me out here because office is really annoying me.
     
  8. Eithanius macrumors 65816

    Joined:
    Nov 19, 2005
    #9
    Those collection of Micro***** apps are too big to be contained within a single package to be moved to a trash can with a single mouse drag... I don't know about 2008, but on their 2011 version I was kinda dumbfounded that M$ doesn't even bother to include an uninstaller... :eek::eek:
     

Share This Page