Cannot Detect Bootable USB.

Discussion in 'Mac Basics and Help' started by PKMN, May 7, 2015.

  1. PKMN macrumors newbie

    Joined:
    May 7, 2015
    #1
    Hi guys,

    OS X decided to stop working on me yesterday, it booted into Safe Mode then restarted and I couldn't boot into OS X not matter what I tried, so I formatted my OS X partition (Was Dual-Booting with BootCamp Windows).

    Now i'm trying to reinstall OS X Yosemite. Firstly I tried to use Recovery Mode (Command + R) to reinstall OSX from the Internet but because my MacBook Pro is from 2010 it's still giving me the Lion install which you cannot download anymore through Recovery.

    So instead I got copy of the OS X Yosemite .dmg and created a bootable USB using Transmac on Windows and created a bootable USB. I tried to run Startup Disk (Holding Option Key at Startup) but it's not recognising my USB. I go into Recovery Disk Assistant and it's there, and i'm sure i've created the bootable USB properly.

    I've run of ideas of how to get the USB detected or to install OS X.

    Thanks.

    TL;DR:
    - OS X Stop Working on my MacBook Pro 2010.
    - Formatted OS X Partition in Mac OS Extended Journal.
    - Cannot reinstall OS X through Internet Recovery because OS X Lion is no longer available.
    - Created a bootable USB using Transmac with Yosemite.dmg
    - Won't read bootable USB when using Startup (Holding Option Key on Startup)
    - Ran out of ideas to get USB to work.
    - Ran out of ideas on how to reinstall OS X.
     
  2. joshjohnson macrumors member

    Joined:
    Mar 16, 2004
    #2
    have you tried letting Lion recovery run? you can still install os x Lion but you need your Apple ID and password to do it. I have a 2010 Mac mini with the firmware update that lets you use internet recovery on it. I ran it just 2 months ago with no issue.
     
  3. PKMN thread starter macrumors newbie

    Joined:
    May 7, 2015
    #3
    Hi, yeah, whenever I tried to reinstall Lion through the Recovery Assistant I would get the error "This item is unavailable." after enter my Apple ID. I believe it's because my Apple Account wasn't the same ID used when the MacBook was first activated.

    Fortunately I was able to solve my problem. It seems that the problem was the Yosemite .dmg wasn't genuine. I downloaded a genuine copy from the App Store using another Mac and followed the steps in the link below to create a bootable USB:

    http://www.macworld.co.uk/how-to/mac/make-bootable-mac-os-x-1010-yosemite-install-drive-3575875/

    And voila, the USB was being read and currently installing OS X Yosemite now.
     

Share This Page