Cannot determine location, Unable to locate you etc

Discussion in 'iOS 8' started by nickthemajin, Oct 22, 2014.

  1. nickthemajin macrumors member

    Joined:
    Oct 22, 2014
    #1
    I've a rather odd issue since upgrading to iOS 8.1. I did a clean update, I restored my iPhone and didn't restore from backup. I started over, so there should be no residual software issues related to backups.

    When I first start my iPhone, location services works fine. But within about an hour or so, no apps can find me. I get "Cannot determine location" in apple maps and "unable to locate you" in any other app. This is fixed if I restart my iPhone but again within an hour it starts doing this again.

    Toggling location services on/off does not fix this. Only completely restarting the iPhone fixes this.
     
  2. nickthemajin thread starter macrumors member

    Joined:
    Oct 22, 2014
  3. HolyGrail macrumors 6502

    HolyGrail

    Joined:
    Nov 21, 2010
    Location:
    Planet Earth
    #3
    Phone's been on for 7 hours. Tried Google maps, and Apple maps. Found me just fine.

    Sorry can't help more.
     
  4. nickthemajin thread starter macrumors member

    Joined:
    Oct 22, 2014
    #4
    So it's definitely not an iOS 8.1 issue. I'm not sure what to do exactly. I've factory reset my phone several times and not restored a backup to no avail. Within about a half hour of my phone being on, all GPS access basically dies. Even Apple's built in maps says, "cannot determine location". But turning the phone off and then back on instantly fixes it for about another half an hour.

    In apps like Yik Yak or NBA game time I get, "unable to locate you". Again just after that 30minutes to an hour window. The first half hour or so the phone works fine. Even toggling location services on or off doesn't work. I have to actually shut the whole phone down.
     
  5. kar120c macrumors member

    Joined:
    Oct 10, 2013
    #5
    Have you tried to switch wifi alway on even wihout any hotspot or connections of every kind?
     

Share This Page