Cannot empty the trash off of my external harddrive!!!

Discussion in 'MacBook Pro' started by macuser1221, Oct 5, 2008.

  1. macuser1221 macrumors newbie

    Joined:
    Oct 5, 2008
    #1
    i have a few external harddrives, and since i updated leopard a few months ago, i have not been able to empty the trash off of the harddrives. i've tried to control empty... still nothing. when i eject each drive, the trash is empty. this is eating up space on my harddrives! any ideas? thank you!!!
     
  2. Eidorian macrumors Penryn

    Eidorian

    Joined:
    Mar 23, 2005
    Location:
    Indianapolis
    #2
    Have you tried removing the files/folders via Terminal or even waiting out a secure erase?

    Are the files locked? Are you the owner of these files? Are they on a HFS+ or FAT32 partition?
     
  3. macuser1221 thread starter macrumors newbie

    Joined:
    Oct 5, 2008
    #3
    hmmm yes they are all my files, and unlocked. secure erase... every time i try it says its deleting way more files than are in my trash. ill wait it out. thanks for the help.
     
  4. mengreco macrumors newbie

    Joined:
    Dec 1, 2007
    #4
    what happened eventually? i have the same problem, when trying to delete there are about 750.000 files to be deleted and taking ages. i ve tried onyx and secure but nothing! any other ideas?
     

Share This Page