Resolved Cannot empty Time Machine backups from trash

Discussion in 'MacBook Pro' started by JayS90, Dec 10, 2011.

  1. JayS90, Dec 10, 2011
    Last edited: Dec 11, 2011

    JayS90 macrumors member

    Jan 2, 2011
    London, UK
    Right, so I've made a majorly idiotic mistake and manually deleted some time machine backups from the Backups.backupsdb folder on my external HD. Now I can't empty the trash ("The operation can’t be completed because an unexpected error occurred (error code -8003)"), and the backups are still taking up God knows how much space on my external HD.

    I've spent hours on Google, browsing forums (Macrumours too!) and trying every terminal sudo command I've come across.

    Can anyone help me? :(


    Re-formatting my external HD would have to be an absolute last resort, as I have gigs of stuff on there that I'd have to find somewhere to back up to first (and my MBP HD doesn't have enough space to store it all in the meantime).
  2. SayMilesAway macrumors regular


    Nov 11, 2011
    I had this issue as well, unfortunately I had to reformat my drive to solve the issue.
  3. desmith1944 macrumors newbie

    Dec 10, 2011
    Maybe a trash fix

    Hi, I am a new MAC user, I just bought a IMac and I started having problems getting the trash to empty.
    I came across a app called Trash it. Not sure where I found it now but, if you Google search you should be able to find it.
    Anyway I loaded and ran the app. If makes it own Trash Icon. I went into my original trash and selected all and drug it into the new Trash it. My computer did nothing for about a minute. I decided to reboot and when I did my Mac trash was empty.
    I hope this helps you and a lot of other users. Dave Smith
  4. grahamnp macrumors 6502a

    Jun 4, 2008
    I've had this problem many, many times. I've had luck manually deleting the .Trashes folder on the Time Machine drive's root directory. It will automatically be recreated.

    Open terminal, type "cd /Volumes" and then "ls" to display all volumes and "cd <<TM volume name>>" to go into the TM volume.

    Type "ls -a" to display all files, the -a is because Trashes is hidden.

    "sudo rm -rf .Trashes" should delete the trashes folder.

    Careful, messing that up could delete the wrong thing. Also, this hasn't always solved the problem for me.

    Time Machine seems to (rather annoyingly) just do it's own thing. I've had it delete the files on its own time before and the free space was back after a certain period of time. I have no explanation for it but it seems to have fixed itself.


    Not entirely related but a word of advice: it seems that you've got data on the same drive as your TM backup, and this is what is stopping you from reformatting. Generally not a good idea to mix backups and your data on the same volume.
  5. JayS90 thread starter macrumors member

    Jan 2, 2011
    London, UK
    Thanks for the advice desmith1944, but this was one of the first things I tried and it had no effect.

    grahamnp, you're actually a life saver! :eek: this totally did the trick, it emptied the trash on my drive and I haven't had to re-format it :D

    I have so learnt my lesson with Time Machine - after the headache it gave me last night I may start using Carbon Copy Cloner instead. Either way, I'm going to partition my external HD and have a partition dedicated to backups instead of mixing my data with them!

    Thanks again, grahamnp! :)
  6. Kateryna macrumors newbie

    Mar 16, 2012
    Please explain to Mac dummy!

    Hi grahamnp!
    I run into the same trouble with Mac: I manually deleted backups, but as soon as I plug in backup disk, I see my trash ful with what I deleted!
    I don't understand what terminal to open. Could you specify the program name or describe all action step-by step as for dummy? I'll be thankful for the rest of my life. I hope you answer. Thank you!

  7. grahamnp macrumors 6502a

    Jun 4, 2008
    No problem.

    To get to terminal:

    Go to spotlight (cmd + space and type '"terminal) or go to your applications folder -> utilites -> Terminal.

    I don't actually understand what you mean by your trash becoming full when you plug your backup drive in. Are you talking about the .Trashes folder taking up space on your backup drive? I don't want to tell you to do anything else without actually getting that straight because the command line allows you to delete pretty much anything, even stuff crucial to the operation of the computer.
  8. twfmike macrumors newbie

    May 29, 2008
    Didn't work for me.

    So, I had the same problem: manually deleted old time machine backups (won't do that again) and then have a full trash folder when the external TM drive is connected, and reduced capacity on the TM drive.

    Tried grahamnp's suggestion. Terminal prompted for my password. I entered that and then..... nothing. Terminal seems to have gone off to do something (ie wont take any further commands) but no change to the trash folder.....

    tried it twice, pretty sure I followed grahamnp's instructions precisely.

    Any ideas???
  9. swb1192 macrumors 6502

    Dec 4, 2007
    You are absolutely amazing. Simply amazing. Thank you so much.
  10. grahamnp macrumors 6502a

    Jun 4, 2008
    No problem.

    twfmike, did you get it fixed eventually. This can take a long time and it does not tell you what it's doing, so it might appear to have frozen.
  11. slinkydge macrumors newbie

    Aug 16, 2012
    Please help

    I have tried this and it's not working for me.

    cd /Volumes ls cd SlinkyDGE then I hit return
    Is -a then I hit return

    at this point it displays the external hard drive as well as my iPod name, iPhone name, even an iPod name from years and years ago!! But not any files/folders.

    any way

    I type
    sudo rm -rf .Trashes
    put my password in
    then I'm back where i started.

    I do have data on the drive that I use for back ups. I didn't know this was wrong.

    Also how are you supposed to get rid of old back-ups the right way??

    even after a re-start it's still there.

    Please help!
  12. swb1192 macrumors 6502

    Dec 4, 2007
    You need to press the return key more often.

    cd /volumes RETURN
    ls RETURN
    cd /[drive name] RETURN
    etc etc
  13. Mythulro macrumors newbie


    Sep 25, 2012
  14. ldcobb2, Nov 6, 2012
    Last edited: Nov 6, 2012

    ldcobb2 macrumors newbie

    Nov 6, 2012
    Okay, so I'm attempting this solution and I type "cd /Time Machine Backups" (the volume name) into Terminal and it says "-bash: cd: /Time: No such file or directory"

    Any suggestions as to what I'm doing wrong?


    UPDATE: I got it to work! Thanks grahamnp!
  15. cowaig macrumors newbie

    Nov 13, 2012
    same problem

    Hi noticed you solved the issue of removing TM backup from trash, gone thro the same route but no joy, im a bit of a novice to Macs, what is the volume name on the part cd <<TM volume name>> ??? any help would be appreciated
  16. cowaig macrumors newbie

    Nov 13, 2012
    Sorted and didn't use terminal method pretty basic
  17. Haaker macrumors newbie

    Jun 26, 2012
    Philadelphia area
    Thank you, thank you! Your advice worked perfectly. I really appreciate it!
  18. Irock619 macrumors 68000


    Sep 16, 2011
    San Francisco, CA
    Doesn't time machine delete backups on its own when space is needed ?
  19. morespce54 macrumors 65816


    Apr 30, 2004
    Around the World

    Couldn't you delete only the "backup.backup" folder (or whichever folder you've deleted) instead of the whole .Trashes folder on the Time Machine drive? Seems more safe to me.
  20. grahamnp macrumors 6502a

    Jun 4, 2008
    No problem!

    Normally, yes. This is for when it fails to do that correctly.

    You could, but one of the issues is that it gets stuck at that point and you go no further. Deleting it moves it to .Trashes so if it won't delete itself after that, doing this will force it. Just make sure nothing else was in the .Trashes folder, it recreates itself automatically after deletion so losing it is not an issue.
  21. niklah9 macrumors newbie

    Dec 11, 2012

    Thanks for the help!! This worked like a charm!! I was dreading having to call Apple to get help with this, thanks again!
  22. QMH macrumors newbie

    Dec 13, 2012
    Hi! I'm having this problem - after typing in "ls -a", there isn't any files being displayed. But in my trash folder, the backups are still there. Where could I gone wrong? This is frustrating! It's taking up a lot of my space.. :(

  23. grahamnp macrumors 6502a

    Jun 4, 2008

    Which trash folder are you talking about? You type 'ls-a' to reveal the trash folder specific to your Time Machine drive, you do this when already viewing the root directory of the TM drive. You delete the entire .trashes folder itself, not the contents.

    Does this help?
  24. schupp411 macrumors newbie

    Feb 9, 2013
    Can't delete .trashes

    I'm having similar issues but when I try to delete the .trashes folder I get the message:

    Benjamins-MacBook:the terror byte Ben$ sudo rm -rf .Trashes
    rm: .Trashes/501/.DS_Store: Invalid argument
    rm: .Trashes/501/How.I.Met.Your.Mother.S08E12.1080p.WEB-DL.DD5.1.H.264-BS [PublicHD]/How.I.Met.Your.Mother.S08E12.The.Final.Page.Part.Two.1080p.WEB-DL.DD5.1.H.264-BS.mkv: Invalid argument
    rm: .Trashes/501/How.I.Met.Your.Mother.S08E12.1080p.WEB-DL.DD5.1.H.264-BS [PublicHD]: Directory not empty
    rm: .Trashes/501: Directory not empty
    rm: .Trashes: Directory not empty
    Benjamins-MacBook:the terror byte Ben$

    Is there a way to delete the files in the .Trashes folder manually or is there something else I should try?
  25. Ccrew macrumors 68020

    Feb 28, 2011
    Try not pirating TV shows from torrents, or at least have the common sense not to post that you do in an internet forum? :)

Share This Page