Cannot empty trash anymore - stuck!

Discussion in 'Mac OS X Lion (10.7)' started by Woutje, Jul 23, 2011.

  1. Woutje macrumors member

    Joined:
    Aug 21, 2005
    #1
    I cannot empty the trash anymore since the upgrade to Lion.

    I've tried the usual tricks like "permanent emptying" or doing rm-rf through the terminal, but they all get stuck.

    Also verifying the disk and restoring permissions didn't change anything.

    It says preparing to empty 6 items, and nothing more happens. When I try to cancel, it stays stuck until I relaunch finder itself.

    Any other ideas?

    BTW, I have a custom SSD installed. Maybe related?
     
  2. Woutje thread starter macrumors member

    Joined:
    Aug 21, 2005
    #2
    Ok, I figured it out.

    I had to start in target disk mode and delete the files using another Mac via the terminal.

    Solved!
     
  3. Polska macrumors member

    Joined:
    Mar 9, 2008
    Location:
    Rio de Janeiro - RJ
    #3
    But then after that, the trash started working fine with no problem? I am having the same problem and I do also have an SSD installed here. I don't have any Macbook Pro on hand right now.

    Thanks for any help.

    Cheers,
    Erick Pessôa
     
  4. Woutje thread starter macrumors member

    Joined:
    Aug 21, 2005
  5. finansvalp macrumors newbie

    Joined:
    Oct 2, 2010
    #5
    Same situation for me, but no SSD disk

    Hi,

    I have the same problem, when trying to empty it, a dialog comes up and say "deleting 527 files" but the progress bar never starts. Can not stop it either. I have run both DiskWarrior and the Disk utility (DVD boot) but it didn't help. I have not an SSD disk, so it can not be because of that.

    Really irritating!
     
  6. xgman macrumors 601

    xgman

    Joined:
    Aug 6, 2007
    #6
    Lion Cache Cleaner app does a better job at clearing the trash from stubborn files.
     
  7. djrbx macrumors member

    Joined:
    Jul 12, 2011
    Location:
    North Hollywood, CA
    #7
    Next time try


    1. Open Applications....... Utilities ....... Terminal
    2. Copy and paste ( chflags -R nouchg ) inside terminal screen. do not press return yet
    3. Open trash bin
    4. Press command-A to select all files at once
    5. Drag them all inside the Terminal screen
    6. Press return
    7. You are done! close everything. open trash and delete all your files.
     
  8. DICKNPHYL macrumors member

    Joined:
    Jul 23, 2011
    #8
    Can't empty trash ?

    Hey! Download "onyx" app.( free) It will empty the trash anytime. You have to find it in the menus of onyx. the app can do many other things too. Maybe after using it to empty your trash, it will solve the problem. hope so
    DICKSTER-----
     
  9. Quad5Ny macrumors 6502a

    Quad5Ny

    Joined:
    Sep 13, 2009
    Location:
    New York, USA
    #9
    Same problem on my 2010 Air (w/ Toshiba SSD). Restarting fixed it.
     
  10. Polska macrumors member

    Joined:
    Mar 9, 2008
    Location:
    Rio de Janeiro - RJ
    #10

    I restarted many times and did not work. I used the Target Mode suggested here and then was finally able to clean the trash. Seems that one file specifically was creating all the trouble. Now all it's normal.

    Cheers,
    Erick Pessôa
     
  11. cryptooth macrumors newbie

    Joined:
    Jul 21, 2010
    #11
    - Restart your mac
    - Open terminal
    - type "sudo rm -rf ~/.Trash/*" without quote
    - press enter
    - type your password
    - press enter

    viola...
     
  12. lijrobert macrumors newbie

    Joined:
    Dec 4, 2011
    #12
    I wrote a small applescript to do this

    I've had this problem so much that I made this
    do shell script "sudo rm -rf ~/.Trash/*" with administrator privileges
    It will force empty your trash for you.
     
  13. Jeiji macrumors newbie

    Joined:
    Aug 16, 2012
    #13
    Worked!

    That whole Terminal thing really does work, for anyone who was wondering. Thanks, Cryptooth and LIJRobert!
     
  14. psaif macrumors newbie

    Joined:
    Aug 29, 2012
    #14
    Totally WORKED!

    Yup the terminal command did the trick! :)
    Thanks, Cryptooth and LIJRobert
     
  15. clouts macrumors newbie

    Joined:
    Sep 12, 2012
    #15
    Empty Trash On Macbook

    It wont let me empty my trash on my macbook, firstly it says secure empty trash, I click that and then it says remove unlocked items or remove all items.

    I jave tried clicking both of these numerous times, can anybody help with my problem.

    many thanks :)
     
  16. \-V-/ Suspended

    \-V-/

    Joined:
    May 3, 2012
    #16
    How about trying the advice already given in this thread?
     
  17. Romeolo888 macrumors newbie

    Joined:
    Jan 26, 2012
    Location:
    China, Shanghai
    #17

    Tried, but still can't delete,

    when typing the command in Terminal, it asks for password, but I am unable to type it in.
     
  18. Leachb31 macrumors newbie

    Joined:
    Dec 16, 2012
    #18
    You Guys Are Complicating This Too Much

    When you are deleting something and the trash gets stuck, more often than not it's because Finder is busy and does not allow the trash process to complete. To fix this, just open your activity monitor, and force quit the "finder" process. You should now be able to empty your trash, and put to the trash anything in finder that you wanted to delete.
     
  19. -Concept- macrumors member

    Joined:
    Dec 11, 2012
    Location:
    In front of a computer. Any computer.
    #19
    Also, if you're sure you won't need to recover anything later, go into your Finder preferences and turn off Empty Trash Securely. What the Mac does when it empties the trash is it stores your files in blocks of memory that can be overwritten, which takes more time.
     
  20. piyushbhartia macrumors newbie

    Joined:
    Feb 24, 2013
    Location:
    India
    #20
    Cannot empty trash anymore - stuck

    Hi !
    I am unable to empty trash and could follow your except how to copy and paste ( chflags - R- nouchg) inside terminal screen. I could reach upto terminal but could not locate, copy (chflags - R- nouchg).




    ----------

    HI
    I am ne to Macrumors.
    I am stuck with my Mac Air OSX 10.8 & unable to empty Trash.
    I came across onyx but could not find in APP Store.
    Please let me know how to download.


     
  21. mackiwilad macrumors member

    Joined:
    Sep 21, 2007
    Location:
    Ask the Goverment!
    #21
    Well, I tried all of the options on this page... and no banana for almost all of them.

    Restarting was a waste of time. Finder/Activity monitor didn't work. The Terminal commands no longer work with 10.10, but I assume this is because of Apple patching the Shellshock vulnerability. I didn't have another Mac to try Target Mode.

    In any case, Onyx saved the day. What a program! It took hours but did the job.
     

Share This Page