Become a MacRumors Supporter for $50/year with no ads, ability to filter front page stories, and private forums.

Dr. McKay

macrumors 6502a
Original poster
Jan 20, 2010
Belgium, Europe
Macbook Pro 14" M1 Pro, Mac OS Sonoma 14.4.1

I had created extra user accounts which I wanted to delete. Got an error message saying the accounts could not be deleted. Still, they were no longer present on login, nor in the Accounts tab in System Preferences.
So I deleted the user folders manually and dragged them to the trash. Only, I can not empty the trash. The folders are seemingly empty yet they must contain files as they are listed on by one when I want to delete them.

I have tried to boot into recovery mode and disabling csrutil (and re-enabling it afterwars, of course), tried with the terminal with the sudo rm command, all no to avail.
I cannot drag them to out of the trash, because then I get the message saying that they can't be copied as they have to be downloaded... which led me to think it might be an icloud problem. But no, I have logged out of icloud completely, rebooted, tried to empty the trash, still no go...

Really don't know what to do anymore. Any suggestions ?


macrumors G5
Visit Apple store and let the bar people resolve the problem?

If you have it all backed up, wipe, reinstall macOS, migration assistant from backup opting to leave out the other accounts and only "import" the accounts you want?

Someone will probably offer a simple option between those two, but I suspect either of those will resolve the problem.
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.