Cannot Enable iTunes Match on iTunes?

bushido

Suspended
Original poster
Mar 26, 2008
8,070
2,754
Germany
am i missing something? the only way to enable iTunes Match is going to the store and clicking on the iTunes Match button right? but when i do that it does nothing after i logged in. it just sits there on the following screen:
 

Attachments

Soni Sanjay

macrumors 6502
Dec 25, 2013
329
884
am i missing something? the only way to enable iTunes Match is going to the store and clicking on the iTunes Match button right? but when i do that it does nothing after i logged in. it just sits there on the following screen:
Go to your account, go to the iTunes Match section, click on "add this computer".
 

bushido

Suspended
Original poster
Mar 26, 2008
8,070
2,754
Germany
theres no such thing, only an option to disable auto renewal. i know where to enable it tho, look at the screenshot but it doesnt do anything after i click the button

edit: i used to be able to enable iTunes Match in the following drop down menu but its no longer there since AM or 12.2
 

Attachments

mpayne2k

macrumors 6502a
May 12, 2010
868
62
am i missing something? the only way to enable iTunes Match is going to the store and clicking on the iTunes Match button right? but when i do that it does nothing after i logged in. it just sits there on the following screen:
Just had the exact same issue. I had to "sign out" of my account in iTunes, quit iTunes, start it back up, sign in, go to iTunes Store, click on iTunes Match, then tried "add this computer" again and it took this time.

The whole "matching your collection" screen doesn't show in 12.2 iTunes, it just has a loading circle which pops up in the upper right of the iTunes window. Once that stops spinning you should have iTunes Match enabled once again.

This bug does suck because if it doesn't recognize you trying to enable iTunes Match you can't view the iTunes store.
 
  • Like
Reactions: bushido

Rigby

macrumors 603
Aug 5, 2008
5,267
5,793
San Jose, CA
I think the link in the store is just a leftover. To enable Match in iTunes 12.2, go into the iTunes preferences and enable iCloud Music Library. Note that they also moved the "Update iTunes Match" menu (it's now under File/Library/Update iCloud Music Library).
 
  • Like
Reactions: Paco II and bushido
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.