Cannot enter DFU mode on Redsnow or Pwnage tool

Discussion in 'Jailbreaks and iOS Hacks' started by Khurram, Jun 23, 2009.

  1. Khurram macrumors 6502

    Aug 28, 2006
    Hey everyone..

    i'm trying to jailbreak using both redsnow or pwnage tool on my 3g 3.0 software.

    Everything is working ok but I cannot get it to enter DFU mode.

    I'm following the directions exactly on both programs but on Redsnow it says entering DFU mode and then it just gets hung up on "waiting for reboot"..I let it sit there 10 minutes and nothing.

    Is something supposed to be on my screen when i'm in DFU mode?
    When I follow it's instructions my phone is just black with nothing on the screen.

    I've tried with Pwnage tool as well but it says "failed to enter DFU mode" everytime I do it.

    I'm hacking my 2g before so I know what i'm doing but this is very frustrating..any tips?
  2. cheapa55 macrumors 6502a

    Oct 29, 2007
    This was happening with my 3G. I couldn't even turn my phone back on. I had to restore in itunes, then went through the process again and it worked.
  3. Khurram thread starter macrumors 6502

    Aug 28, 2006
    So now I got it into DFU mode but when I open up Itunes it just says "waiting for ipod" Then after about 5 minutes of waiting it says..An ipod was found but could not be identified. An unknown error occured (1601)
  4. Khurram thread starter macrumors 6502

    Aug 28, 2006
    This must be the reason that everything is getting hung up in redsnow as doesn't reboot automatically like it should in DFU mode..

    I guess i'll restore through itunes and try again.
  5. Khurram thread starter macrumors 6502

    Aug 28, 2006
    Restored using Itunes and still the same issue.
    When I put it in DFU mode it just gets hung up in Itunes on the "waiting for ipod screen"

    Then after a few minutes it says ipod could not be identified.
    what's going on?!
  6. Moi un Mouton macrumors 68000

    Mar 18, 2008
    Bracknell UK
  7. Khurram thread starter macrumors 6502

    Aug 28, 2006
    I've never had a USB port issue before...
    this is the first time i've had this issue..
    i'm on a mac
  8. vertigo78 macrumors regular

    Oct 2, 2008
    i had the same problem on my macbook pro when using both pwnage and redsn0w. i think this might be the same usb issue that was introduced with a leopard update a few months back where iphones in dfu mode couldn't be recognized. try using another computer. that's what i did and it ended up working immediately. (used a windows machine) you could also try using a usb hub.
  9. Khurram thread starter macrumors 6502

    Aug 28, 2006
    Tried doing it on my windows machine.

    I get it into DFU mode then a little bubble pops up in windows saying DFU USB recoginzed and the install wizard comes up..I canceled the install wizard but then Redsnow says no device connected.

    Ahhhhhhhh this is driving me mad!
  10. Moi un Mouton macrumors 68000

    Mar 18, 2008
    Bracknell UK
    Which install wizard? Maybe you need to let that run, there are new drivers involved in DFU mode.
  11. Khurram thread starter macrumors 6502

    Aug 28, 2006
    Got it to finally work on my macbook air using a usb hub.

    I guess they really have disabled using the phone in DFU mode in certain leopard updates
  12. bytethese macrumors 68030


    Jun 20, 2007
    Yes, 10.5.6 had a "USB bug". Using a powered hub was a suitable work around, or updatign to 10.5.7 resolves this as well. :)
  13. fox777 macrumors regular


    Nov 11, 2008
    Guys i am having absolutely exact problem as OP. The only thing is that I am using Redsnow 0.8 and trying to JB Iphone 3GS... For some reason it will not enter DFU mode and instead of entering DFU mode and showing up like one on desktop it says "Found new USB"

    Can anyone help?
  14. euteneier macrumors newbie

    Jul 6, 2010

    hi i have a 2g ipod touch 4.0, i tried using redsnow on windows but once i try putting it into dfu mode it freezes before it can do anythin else so i have to plug it into itunes to reboot. i tried like 5 times and it allways ends up the same. can anyony help :(
  15. smokegfx macrumors newbie

    Apr 1, 2011
    I had the same problem and it turned out to be because I tried to jailbreak my iPhone on a pc without iTunes installed.
    After I installed iTunes it worked perfectly.
    Registered just to post this, hope it helps someone.
  16. aardwolf macrumors 6502

    May 30, 2007
    Helped me... Thanks!
  17. kosheriphone macrumors newbie

    Apr 6, 2011
    im gonna try this just posted a new thread and saw everyone has this problem
  18. Rizvi1 macrumors 6502a

    Mar 29, 2006
    Laurel, MD (Baltimore, MD / Washington, DC area)
    Old thread but I just had the same issue. Switching the USB port on my mid-2010 MacBook Pro got me into DFU mode in PwnageTool.
  19. nexus750 macrumors newbie

    Mar 14, 2012
    DFU mode Prob

    Hey guys,
    I am using windows machine and i have tried all the possibilities still i am having the same issue, that my iphone 3g is not going into DFU mode neither with redsnow nor with anyother jailbreak program.
    So what should i do now ???

Share This Page