Cannot for the life of me enable noatime

Discussion in 'macOS' started by Crackhorse, Aug 4, 2011.

  1. Crackhorse macrumors newbie

    Apr 20, 2011
    I just got a SSD off craigslist yesterday and since then, in an effort to tweak everything I can about it, I've been trying to enable noatime, but to no avail.

    Here is what I have -

    a .plist file in Library/LaunchDaemons called com.noatime.root.plist

    within that file there is the following code -

    <?xml version="1.0" encoding="UTF-8"?>
    <!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "">
    <plist version="1.0">

    And as some sites suggested I assigned read and write privileges for everyone on this file and ran the following in terminal -

    sudo chown root:wheel /Library/LaunchDaemons/com.noatime.root.plist

    after restarting, when I submit the command: mount , I receive the following

    /dev/disk0s2 on / (hfs, local, journaled)
    devfs on /dev (devfs, local, nobrowse)
    map -hosts on /net (autofs, nosuid, automounted, nobrowse)
    map auto_home on /home (autofs, automounted, nobrowse)

    I am running this SSD on a 13" MBP 2011. It is the sole drive with OSX version 10.6.8, fully updated. The SSD is an OCZ Agility 3.

    I hope someone can help as its incredibly frustrating.

  2. Crackhorse thread starter macrumors newbie

    Apr 20, 2011
  3. Modernape, Aug 9, 2011
    Last edited: Aug 9, 2011

    Modernape macrumors regular

    Jun 21, 2010
    I just enabled it successfully on an OWC Mercury with the instructions on the last post here -

    Which corresponds with the instructions seen here

    and also seen on the OCZ forum here

    2 problems with your code:
    the line -
    seems to differ from the line used in all 3 of the above, which is -
    also, your line -
    should not have /Library/LaunchDaemons/com.noatime.root.plist on it at all, just plainly
  4. timrichardson macrumors newbie

    Aug 5, 2011
    I had to do one more step...

    I just got a Samsung 830 SSD for my macbook, which is also upgraded to OS X 10.8 Mountain Lion
    After making the plist file, I needed to do one more step:
    sudo launchctl load /Library/LaunchDaemons/

    (the last part being my plist of course).
    This seems to register the plist to be executed.

    This worked on the next reboot. This extra step comes from the help file for the app Lingon 3

Share This Page