Cannot Force Quit WebEx process (nor can I find it)

Discussion in 'Mac Basics and Help' started by Praxis91, Mar 20, 2014.

  1. Praxis91 macrumors regular


    Mar 15, 2011
    Hi all, I have an annoying issue. I have searched these forums, as well as Cisco and anywhere else I could think of searching, but no luck.

    It does not happen all the time, but enough that it's annoying. Basically, I will join a WebEx meeting and after it ends, I will close/leave the meeting, but the WebEx icon still remains in my dock. It does not happen all the time, but maybe 40-50% of the time, and I do nothing differently.

    If I right click it and force quit, nothing happens. On the right click is just says application not responding and it's grayed out. If I click the Apple and select WebEx to force quit that way, nothing happens. When I go to terminal and type "top" the process is not listed. When I go into activity monitor, the process is not listed.

    If I go to the dock icon and select "Show all Windows" I then see my desktop background but nothing else. If I click anywhere on screen, it goes back to whatever I was looking at before. The only way to get rid of it is by restarting, which I hate doing because I am also running Parallels 9 all day for work.

    Is there yet another way to kill the process? I have triple and quadruple checked activity monitor and nothing relates to WebEx. It's an issue because if I have another meeting coming up, the browser tells me that I'm already in another meeting and that I have to leave my other one...which I already did. :confused:

    Any thoughts or suggestions? I have already tried reinstalling after rebooting.
  2. jfield macrumors newbie

    Mar 27, 2014
    Same Issue

    I'm having the same issue, tried the same steps and no process shows to be running.

    The problem seems to happen if I don't close out of the webex app before the computer goes to sleep. I try and make a mental note to close the webex app right after a meeting but sometimes still forget.

    I have to force a power off, as reboot/shutdown just hang because that app won't close.

    Looking for a way to fix it.

  3. Praxis91 thread starter macrumors regular


    Mar 15, 2011
    I have not gone to sleep before a meeting ended, but it's good to know I'm not the only one with a similar issue. A reboot does fix it for me though.

    However, this week, I decided to run WebEx from within my W7 VM (Parallels) and it works fine there.
  4. wrldwzrd89 macrumors G5


    Jun 6, 2003
    Solon, OH
    I suspect that what's going on is that WebEx is not, in fact, running, but your Dock thinks it is. This is easily corrected by restarting the Dock process.
  5. I'm a ROb macrumors member

    Aug 14, 2007
    If the dock restarting doesn't solve it:

    Run a 'top' in terminal during your session and get the PID, so you could do a 'kill' after or during the session. Or of top doesn't list it, try 'ps aux'
  6. Praxis91 thread starter macrumors regular


    Mar 15, 2011
    Thanks! I'll try one/both methods when it happens again!
  7. eddieb3 macrumors newbie

    Jun 29, 2007
    Same thing with me

    I have had this issue for a few months on my 2010 iMac running Mavericks. Happens every time except when I've periodically uninstalled and then reinstalled Webex to see if maybe a new version of Webex might have a fix for it applied. After that first reinstall, it doesn't happen for my first meeting but then happens again every time thereafter.

    I don't think it's an issue with just the dock thinking it is there because I also run the Cisco IM client Jabber which shows your status with Webex and when Webex gets stuck open, Jabber shows my status as being in a meeting, so it thinks Webex is open too.

    I have a 2009 MacBook Pro running Mavericks that I use for Webex as well and it doesn't have this issue. Only my iMac. Drives me crazy, I have to do a hard reboot (hold the power button down for 5 seconds), but at least my iMac boots back up pretty damn fast and saves all the open apps I had - even those in my browser that i was signed into. So it doesn't waste too much time. But still REALLY annoying!
  8. drumnow macrumors newbie

    Apr 28, 2014
    Same problem.

    There is no "process" associated with the Webex client. I did find what appears to be a mozilla process in the middle of a dump. When I stopped that (using terminal) the dock item went away.

    ps -aux | grep mozilla
  9. eddieb3 macrumors newbie

    Jun 29, 2007
    After 2-3 years of this behavior, suddenly, in the last week, this hang with a required force quit no longer happens. I don't know if there was an update, if I did something or what. Not sure why it's suddenly not happening anymore, but glad that's the case now.
  10. TorchUK macrumors newbie


    Jun 10, 2016
    Eastbourne, UK
    How infuriating. I have never had this issue until last week. Now I can't Force Quit the app or close down my MacBook Pro running El Capitan! Exactly the opposite to @eddieb3 . I certainly haven't made any changes so looks like an automatic update that fixed for others but messed it up for me :-(
  11. regis.cabaret macrumors newbie


    Jun 23, 2016
    I have had the same problem for the past two months and can't do anything about it except restarting the computer... Even the `killall Dock` won't do the trick.
    I encountered the same with another application (Interactive Brokers Traders Workstation).
    Could it be due to Java Runtime Environment?
  12. jbwaits macrumors newbie


    Jul 26, 2016
    I am having the same issue... I cannot Force Quit Cisco WebEx Meetings...

    ... furthermore, I host several meetings with WebEx... and I cannot start the second meeting, without a reboot of my MacBook Pro.

    Any advice, anyone?
  13. ocabj macrumors 6502a


    Jul 2, 2009
  14. patilashok macrumors newbie

    Dec 27, 2017
    Thank you. This post helped me to find the culprit. AnyConnect of cisco was running an agent that was causing this issue with message "You already have one meeting in progress. You can start or join a new meeting after you leave the previous meeting."

    After uninstalling AnyConnect. I am able to join and start as well webex meetings with the irritating message.

Share This Page