Resolved Cannot format or install OS. Weird bugs.

Discussion in 'MacBook Pro' started by maxmaut, Oct 18, 2015.

  1. maxmaut macrumors regular

    Joined:
    Nov 13, 2011
    #1
    This is a thread of doom.

    Everything started with Chrome not loading anything. I tried Safari and it worked, but was showing certificate issues all the time.

    I rebooted the computer and it became extremely slow. Apps were not launching, Safari kept showing certificate issues.

    I somehow managed to open Activity Monitor and saw a bunch of processes taking 100% of CPU. I stopped them but the system was still laggy.

    Further rebooting was showing just re-opened windows, one at a time, no dock, no status bar. Cmd+option+esc worked, I could kill processes, but could not launch anything, hence no finder access.

    At this point I saw that somehow CleanMyMac toolbar loaded, stating there is ZERO kb space available. I tried rebooting again and that's when it stopped booting. Just constantly stuck on grey logo and spinner. Resetting PRAM did not help. It did not boot in safe mode too.

    I made a mavericks bootable thumb drive. It did not install on top of the old system (mountain lion), showing error that it cannot re-partition the drive. I googled every single solution, and thought that the issue is that there is some runway log, that kept growing and took all the space (50GB was free couple days ago).

    So I've decided to use terminal when booted from a thumb drive to delete some files with rm command. I could not do that too, since there were issues with ACL. I did not have rights to delete files, I could not assign them to me either. CHOWN, CHMOD, nothing helped, showing error INVALID ARGUMENT.

    I struggled with this for around 8 hours, looked up every topic and tried every solution, being sure that I need to delete some files and it will start working. Then I've decided to try working not from the thumb drive's terminal, but to launch recovery mode (cmd+R) and use Lion's terminal. It did not help too, but during on of the reboots I failed to press option AND IT LOADED.

    Yes, it loaded, I saw the wallpaper and was super happy about it. But, finder was showing everything empty, and those processes were back, taking 100% CPU. They were quicklookd and iCloud Photos. I managed to open preference pane, but nothing there worked. I was getting errors like "failed to load iCloud preference pane".

    I've checked the free space on the hard drive, and 50 GB of free space were there.

    Nothing worked so there was nothing I could do except restart again, and it was the last time it actually started the OS.

    And now comes the best part.

    All this time (from around midnight till now – 11AM) I was trying to save data. But at this point after 11 hours of failures I decided to just erase the drive and do a clean install. I went to erase it from recovery mode's Disk Utility, and it failed formatting it. "System formatter failed" Error, no matter what I do and what kind of partitioning map I choose. It does not format in Mac OS journaled, I cannot re-partiotion, nothing. It formats in MS-DOS super quick though.

    So I spent 11 hours, did not sleep and decided to do a last thing I could – quickly ran to my office, brought home an external adapter, gout out the drive from the laptop and connected it to my other laptop as a USB external drive.

    I am able to format it any way I want, any partitions, any names, anything. But as soon as I put it back into the laptop and try installing system on it I get another error – failed partitioning the "File system formatter failed. Quit the installer to restart your computer and try again".

    After this I am officially done trying to fix it alone and I need your help. ANY idea would do.

    It's a 2010 MBP 13 inch, the drive is Samsung Evo 300GB SSD.

    Thanks guys.
     
  2. simonsi macrumors 601

    simonsi

    Joined:
    Jan 3, 2014
    Location:
    Auckland
    #2
    I'm guessing your "other laptop" isn't an MBP? If it is, see if you can install a system on the drive while it is connected as an internal, then boot from it as an external. If that works the drive is good and I'd suspect the internal drive cable is bad.

    If the other machine isn't an MBP, I'd try and use your bootable thumb drive to boot from and see if you can install a system on the SSD while it is connected externally as above.
     
  3. maxmaut thread starter macrumors regular

    Joined:
    Nov 13, 2011
    #3
    My other laptop is a MBP, but the 2015 one where I cannot swap drives.

    I will try installing it on the external drive now.
     
  4. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #4
    From this description of the drive working fine over USB on the other machine, but not working internally on the main machine, this sounds like a bad internal drive cable. Fairly common issue.
     
  5. maxmaut thread starter macrumors regular

    Joined:
    Nov 13, 2011
    #5
    So, I've managed to re-partition the drive from the other laptop and install Mavericks on it. Yay!

    Now when i put it in the laptop and launch it shows the error. "Unapproved caller. Security Agent may only be invoked by Apple software".

    Tried restarting in safe mode. Does not boot, stuck at half a progress bar.
     
  6. BrettApple macrumors 65816

    BrettApple

    Joined:
    Apr 3, 2010
    Location:
    Heart of the midwest
    #6
    Plus one for the cable. I had crazy issues like this on a friends 2012 13" MBP with a Crucial SSD that was throwing errors all over the place. Especially bad CRC/UDMA events indicating a bad cable. Once I put a new one in (from a dead MBP I had) it worked perfectly. Drive was totally fine but the cable was causing all heck to break loose.

    Does the drive boot fine on your other MBP? If so, it's very likely to be the cable and not the drive. If it still throws errors on your newer MBP then it could be the drive.
     
  7. maxmaut thread starter macrumors regular

    Joined:
    Nov 13, 2011
    #7
    Ok, so both computers boot from that SSD if it's connected via USB, but if I put it inside it shows the error.

    So what, this is a cable issue after all? Are we positive?
     
  8. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #8
    As sure as we can be. What you did is the true test... it works over USB, but not when installed with that cable internally, so that makes the cable the only variable.

    I suppose it could be the logic board where the internal cable connects, but I have not heard of that happening. The cables failing on these seems to be becoming fairly common now as they age.
     
  9. maxmaut thread starter macrumors regular

    Joined:
    Nov 13, 2011
    #9
    Guys you all are incredible! Foolish me thought this was a software issue all along, lost all the data and what seems like a half of my life on this, and it truly is a cable issue.

    I did a quick fix/test to make sure it is cable and put tape on the bottom of it, just like this guy

    And it booted. Thank you all, you guys are amaaaaazing.
     
  10. old-wiz macrumors G3

    Joined:
    Mar 26, 2008
    Location:
    West Suburban Boston Ma
    #10
    And get rid of CleanMyMac - it is well known for screwing up OSx.
     

Share This Page