Cannot get correct printer drivers

Discussion in 'Mac Basics and Help' started by BdON003, Jan 16, 2008.

  1. BdON003 macrumors newbie

    Joined:
    Jan 12, 2008
    #1
    Hello there! I just received my first mac today, a macbook. I am having troubles already trying to get my printer that is connected to my other computer to work. My other computer has Linux/Windows and I am trying to get it to work while it is running windows, first. The printer is a Canon Pixma MP470. It works fine in windows, and when I try to print in OS X, I went to "add printer" -> "Windows" button -> "Canon MP470". That's no good though. Oh, first before that, I did put the CD that came with the printer and went through the setup and installed everything on it. What happens now is the printer recognizes there is a job because it moves the nozzles and pulls a piece a paper through whenever I send a job, but with no printing on it.

    So I plugged the printer directly into my MB, and it also worked. It recognized my printer and under the "driver" tab, it displayed "Canon MP470 series", but was grayed out. When I try to select the driver for it when it is through my network, I don't have a driver called "Canon MP470 series", the closest I have is "Canon PIXMA MP500 - Gutenprint v5.1.3", which is what I have been using.

    Also, is there anything else I need to know about getting it to work when my computer is running linux? I will be using CUPS in linux.
     
  2. BdON003 thread starter macrumors newbie

    Joined:
    Jan 12, 2008
    #3
    Wow, it worked. I thought I downloaded and installed all of the different drivers from that page. thanks none the less
     
  3. NAG macrumors 68030

    NAG

    Joined:
    Aug 6, 2003
    Location:
    /usr/local/apps/nag
    #4
    Er wait, the driver page I linked to you worked or you fixed it differently?
     
  4. BdON003 thread starter macrumors newbie

    Joined:
    Jan 12, 2008
    #5
    That page you linked me to worked. It was just I thought I had tried all of the drivers from that page previously.
     
  5. 123walter macrumors member

    123walter

    Joined:
    Jun 26, 2008
    Location:
    Petersburg VA
    #6
    Wireless Printing Macbook Pro-Canon Pixma 470

    You may have to download newer Gutenprint drivers until you get the MP150 v5.23 Gutenprint. I dont think it was there until I downloaded new ones. Then using Print-Fax. Choose Windows- Then there wll be a page with three columns, Workgroup-Computer-Printer. Find your printer. Add it. Use the MP150 driver. It will work. If you have sharing enabled everywhere. Also I added myself as a user on Cups website. Dont know if thswas required.
     

Share This Page