Cannot get Leopard CD out of mac notebook

Discussion in 'Mac Basics and Help' started by iamchristine, Dec 20, 2014.

  1. iamchristine macrumors newbie

    Joined:
    Dec 20, 2014
    #1
    I have a notebook and desk model macs.
    They are outdated, so I installed leopard (had cd on hand) on my desk model to use until I buy a proper CD with update.
    Mac OSX
    Version 10.5/8
    Processor 2 CHz Intel Core 2 Duo
    Memory 1GB 667 MHz DDR2 SDRAM

    If I try to update software, I can't as it says I am outdated......so that will do for now until I find out how to do it.

    PROBLEM:
    mac notebook
    I tried to fix it with restore disc, but 2nd disc was damaged. So I put the same leopard in as I used with my desk top. It wouldn't upload it on the notebook. I have tried everything to get that disc out of there and I can't do it. I don't know how to get it out, would someone please help me?

    (reason I was trying to fix the notebook with a restore disc is because when I tried to turn it on, all I ever got was a flashing question mark).
     
  2. bunnspecial macrumors 603

    bunnspecial

    Joined:
    May 3, 2014
    Location:
    Kentucky
    #2
    Just an idle thought-

    You might try first booting into boot manager by holding down the "option" key when starting up. When boot manager pops up(which shows all bootable volumes) try ejecting the disk using the eject key on the keyboard.
     
  3. Brian Y macrumors 68040

    Joined:
    Oct 21, 2012
    #3
    Power the machine off completely, hold the trackpad button down and press the power button to turn the machine on. Don't let go of the trackpad button and it should spit the disk out.
     
  4. iamchristine, Dec 20, 2014
    Last edited: Dec 20, 2014

    iamchristine thread starter macrumors newbie

    Joined:
    Dec 20, 2014
    #4
    Ok, I tried the first suggestion. Didn't work. I don't have an eject key on the keyboard.

    Second suggestion, I don't know what a trackpad button is as I don't see one on the keyboard.

    OK, I googled trackpad button to see what it is. Long bar just under the flat part that you use as a mouse.
    I did as you suggested, didn't spit it out.

    Any other suggestions anyone?
     
  5. bmac89 macrumors 6502a

    bmac89

    Joined:
    Aug 3, 2014
    #5
    I don't know if this will work, but worth a try.

    Go into 'Disk Utility' and click on your optical disc drive and press the eject button.
     
  6. DeltaMac macrumors 604

    DeltaMac

    Joined:
    Jul 30, 2003
    Location:
    Delaware
    #6
    Here's a couple of the several methods to eject CDs on your Mac:
    On your MacBook keyboard, the eject button is the top right corner button - the keycap looks like a triangle with a line underneath (It does not have the word "eject" on the key, only the symbol)
    If you don't see that symbol on your keyboard, then the f12 key will work as an eject key.

    Your trackpad button is NOT an eject key, but will force the CD to eject shortly after the screen lights up, if you restart your Mac while holding that trackpad button down.
     
  7. iamchristine thread starter macrumors newbie

    Joined:
    Dec 20, 2014
    #7
    Thank you so much!!

    Thank you, thank you, thank you friends. It worked.

    I held down the trackpad button while restarting and kept it down until the disc popped out. I couldn't believe it, I had been at this thing all day...

    I really appreciate your help.

    Christine
     
  8. bmac89 macrumors 6502a

    bmac89

    Joined:
    Aug 3, 2014
    #8
    Good to hear you got it working!

    For the record you can also do the same thing on an imac by holding the mouse button at startup.
     
  9. iamchristine thread starter macrumors newbie

    Joined:
    Dec 20, 2014
    #9
    Thank you so much!!

    You people were really good to me here and helped me with my problem so well, that I am hoping you will help me again.
    I am ready to update my mac desktop and notebook. Here is the thread I started. I would love it is you would help me again.
    http://forums.macrumors.com/showthread.php?t=1833551
     

Share This Page