cannot get monoprice.com gigabit USB adapter working (10.7)

Discussion in 'MacBook Air' started by gnychis, Jan 25, 2012.

  1. gnychis macrumors 6502

    Joined:
    May 24, 2009
    #1
    I did some searching for Ethernet adapters in this forum and found the monoprice.com adapter that a lot of people were keen on. So, I ordered it and found the newest drivers here:
    http://www.asix.com.tw/download.php?sub=driverdetail&PItemID=84

    I installed the driver, and the device shows up in my USB devices list, but it doesn't show up in the Network preferences to add to my list of networks/devices:

    http://www.flickr.com/photos/gnychis/6762170081/sizes/l/in/photostream/

    Anyone else experience/solve this?
     
  2. TheRealDamager macrumors 65816

    Joined:
    Jan 5, 2011
    #2
    I know you don't want to hear this, but this is EXACTLY why I tell people to just buy the Apple version. Its several dollars more, but you avoid all this driver nonsense.
     
  3. gnychis thread starter macrumors 6502

    Joined:
    May 24, 2009
    #3
    it's not about the $$$, it was about the fact that it supported a higher rate. People have gotten it to work and it's recognized as a device... I'm patient for great success.
     
  4. TheRealDamager macrumors 65816

    Joined:
    Jan 5, 2011
    #4
    The USB port does limit the speed you will see. But good luck - hope it works out.
     
  5. posguy99 macrumors 6502a

    Joined:
    Nov 3, 2004
    #5
    Something you plugged in without loading any driver at all would be "recognized as a device".

    You can't get gig speeds out of a USB port. For the seldom times when you need to use it, "it just works" is better than some hacked solution.

    Buy the Apple, supported, adapter.
     
  6. agentphish macrumors 65816

    agentphish

    Joined:
    Sep 7, 2004
    #6
    USB Port upper limit is 400, gigabit is 1000. Naturally this whole argument makes no sense when talking about "gigabit ethernet over usb" because it will never be true.

    Buy the Apple one.
     
  7. esserdk macrumors member

    Joined:
    Mar 15, 2009
    #7
    Would you guys please stop this?

    He is asking for help. Not for your judgments.

    I, for one, hope that you succeed.
     
  8. TheRealDamager macrumors 65816

    Joined:
    Jan 5, 2011
    #8
    We are not judging. We are trying to help him understand that basic physics stand between him and his goal. We are trying to share our experience - isn't that what these boards are all about?
     
  9. shaown macrumors regular

    Joined:
    Mar 24, 2011
    #9
    This is easy to settle.
    1) Apple USB Adapter (which I use), plug and play, works easy

    2) Monoprice Gigabit Adapter, is cheaper, is FASTER (noticeably so - easily can double throughput even with USB 2.0 limitation and get 200-225 effective when It tried it). Can be difficult to setup, especially if a new OS revision breaks compatibility.

    If u care about easy setup - go 1. If you care about speed or price go 2.

    -Shaown
     
  10. JHUFrank macrumors 6502a

    JHUFrank

    Joined:
    Apr 16, 2010
    #10
    This is not going to help the OP, but it clarifies using Monoprice adapter. I only use the MP adapter for my MB Air. As a matter of fact, I have 2 of the damn things. They work great, IMO (anecdotal, I know), and are much less problematic on my MBA, 2010, OSX 10.6.8.

    Sounds like this is a Lion driver problem. Maybe want to contact Monoprice for an updated driver?
     
  11. gnychis thread starter macrumors 6502

    Joined:
    May 24, 2009
    #11
    Hmmm, yeah they posted new Lion drivers and I tried installing those but it doesn't seem to work still. I was thinking of maybe RMA'ing it and maybe it is just a faulty one I received. I'd like to try it on another MacBook or something to double check.
     
  12. sundragon, Jan 30, 2012
    Last edited: Jan 30, 2012

    sundragon macrumors regular

    sundragon

    Joined:
    Dec 27, 2011
    Location:
    Washington, DC
    #12
    Not so fast, buddy...

    Love all the technical advice given without any first hand experience. Please list first hand experience if you're gonna be helpful....

    So here is my first hand experience that I posted on Apple's Support forum:

    https://discussions.apple.com/message/17225497#17225497

    I wanted to take advantage of the 480mbps of USB2 which is theoretically 4.8x the speed of Apple's 100mbps...

    I did my own testing because no one had any experience:

    ****************************************************

    I tried to find more information about the Presto unit but their website is horrible - No information about their own product aside from a press release and a pretty picture.

    I guess no one has tried this little comparison so what the ****, I might as well and post my results. I went to Micro Center and purchased a Belkin Gigabit USB 2.0 Network Adapter.

    Here are my results.

    802.11 N Wireless to my Time Capsule (1st gen)
    Write: 7.3 Mbps (58.4 mbps)
    Read: 7.6 Mbps (60.8 mbps)


    Apple USB "Fast" Ethernet adapter to Time Capsule (1st gen)
    Write:11.1 Mbps (88.8 mbps)
    Read: 8.2 Mbps (65.6 mbps)


    Belkin "Gigabit" USB 2.0 Network Adapter to Time Capsule (1st gen)
    Write: 20 Mbps (160 mbps)
    Read: 28 Mbps (224 mbps)

    So there you have it - I don't expect to get Gigabit speed 125 Mbps (1000 mbps), but getting nearly twice the write speed makes backing up and restoring a lot faster. Interesting to note - I have read posts that state there will be issues with Gigabit (1000 mbps) over USB 2.0 (480 mbps) - I noticed none...

    The Belkin adapter is not as pretty as the Apple adapter - The blue LEDs can be used as a flash light they are so bright, but it does a better job.

    **********************************************************

    I don't have any special drivers - you just plug and it works. I would recommend returning the Monoprice adapter and purchasing the Belkin one. I bought mine from Microcenter locally for a little cheaper than this:

    http://www.amazon.com/Belkin-F5D5055-Gigabit-Network-Adapter/dp/B000FOWHTI/ref=sr_1_2?ie=UTF8&qid=1327949670&sr=8-2

    Good luck :)

    ----------

    Hi...

    I have first hand experience that a USB 2.0 gigabit adapter works without drivers and 2x the speed of the Apple branded one...


    I have posted my own benchmarks etc in order to help. Please let me know which non-apple gigabit USB adapter you used that failed.

    Thanks :)
     
  13. gnychis thread starter macrumors 6502

    Joined:
    May 24, 2009
    #13
    It appears that newer versions of this Monoprice adapter going around actually use a different chipset. The newest review on Monoprice points out that it no longer uses an ASIX chipset, but rather an SMSC chipset:
    http://www.monoprice.com/products/p..._id=1031102&p_id=5345&seq=1&format=4#feedback

    My adapter is at home (i'm at work), but I will try this later. Hopefully this helps someone else purchasing this adapter new. Seems like this transition is just happening now.
     
  14. TheRealDamager macrumors 65816

    Joined:
    Jan 5, 2011
    #14
    Thanks for the benchmark. For you, clearly, the speed increase (which by the way is WAY, WAY under GB, which was the topic under discussion) is worth having to mess around with drivers. I'm glad to hear it is working well for you - for now. Because there will come a Mac update in the not too distant future which will make it not work. And then you'll be fumbling around looking for a driver - like the guy who started this thread.

    I make my recommendation to just buy the Apple one because I previously bought 2 different 3rd party adapters, both of which had issues either right away or right after an upgrade of MacOS. For me, and obviously for other users, a potential speed increase isn't worth messing with drivers and the potential for things breaking when the operating system gets updated. For you it's a risk worth taking (for now). That's cool.
     
  15. sundragon, Jan 30, 2012
    Last edited: Jan 30, 2012

    sundragon macrumors regular

    sundragon

    Joined:
    Dec 27, 2011
    Location:
    Washington, DC
    #15
    I am not using drivers. There are no drivers necessary with this adapter. If you check out the reviews on Amazon, older versions of the Mac OS haven't needed drivers.

    LOL, "...is WAY, WAY under GB..." is still 2-3x faster (for the same price) :)

    P.S. It's worked for me since 10.7 - 10.7.2
     
  16. TheRealDamager macrumors 65816

    Joined:
    Jan 5, 2011
    #16
    Once again, I'm glad it's working for you. A track record of 10.7-10.7.2 isn't very long, but best of luck moving forward. I can just share with you that more than likely a day will come where it doesn't work, and for me and many others, the speed increase (which you are likely only really using a tiny fraction of the time) isn't worth the hassle. Having said that, others feel differently - thats what makes these boards great.
     
  17. sundragon macrumors regular

    sundragon

    Joined:
    Dec 27, 2011
    Location:
    Washington, DC
    #17
    - Since I may not have tested this device with older versions of Mac OS - Please read the list of 4-5 star reviews (on Amazon.com) that other Apple users have given the device using older versions of the OS = Historical data.

    Belkin has apparently designed a component that has worked with with Apple OS updates - Worrying that all of a sudden (without any historical or substantive evidence) that it will no longer be supported is weak logic.

    Using your logic Apple will probably drop it's support for it's own adapter when the new Macbook Air/Pros come out with USB 3.0 and Apple releases it's own USB 3.0 to Gigabit adapter. Apple is known to limit support to older equipement so this is a more plausible possibility.

    The point is that there are alternatives to the Apple Adapter which provides nothing other than the Apple logo and better industrial design.
    • Not price
    • Not speed
    • Not driver free functioning.

    I see people giving "advice" on these forums based totally on untested theory and opinion - When someone walks up and pokes a hole through it they become defensive.
     
  18. TheRealDamager macrumors 65816

    Joined:
    Jan 5, 2011
    #18
    I'm not being remotely defensive. I'm sharing my experience (and the experience of others in the thread above supports me). I've also stated multiple times that I'm happy you are pleased with your purchase. You seem to have to be "right" about something, but I would hope you would put your efforts into something more productive that this. Once AGAIN, glad to hear your personal experience, and I restate my opinion that a few extra dollars is not worth a potential headache. Feel free once again to have the last word - I'm moving on.
     
  19. sundragon, Jan 30, 2012
    Last edited: Jan 30, 2012

    sundragon macrumors regular

    sundragon

    Joined:
    Dec 27, 2011
    Location:
    Washington, DC
    #19
    I work in IT and support clients who have similar issues as the individual who started this thread.

    I witness people do exactly what you just did - give baseless opinion without any research, facts or statistics to back it up. I scrolled up and re-read the thread to see if I had misread your responses - that you actually stated definitive facts yourself - but no not even a model number of the product you owned/used that had issues.

    Then finally when a hole is poked in your argument, you use smarmy comments to cover your exit.

    I'm glad you've moved on because I've made my point to satisfaction.

    **********************************

    To the individual who purchased the monoprice.com adapter - you should find out if you have the ASIX or SMSC chipset and google "ASIX" or "SMSC" to see if the chipset manufacturer has Lion drivers - apparently the chipsets are used in quite a few USB to Gigabit Ethernet adapters and the adapter manufacturer may not provide a driver but the chipset manufacturer may.

    Alternatively - return it and get one that is proven to work.

    Cheers, and good luck! :)
     
  20. gnychis thread starter macrumors 6502

    Joined:
    May 24, 2009
    #20
  21. torana355 macrumors 68020

    Joined:
    Dec 8, 2009
    Location:
    Sydney, Australia
    #21
  22. antonis macrumors 68000

    antonis

    Joined:
    Jun 10, 2011
    #22
    I'm using ethernet adapter from Monoprice for some months now and indeed is a much better choice than Apple's. Having using both of them under different networks (office & client's sites) the speed difference is more than noticeable.

    Until the first thunderbolt ethernet adapters are widely available, I can't help and consider the Apple adapter a real stealing. More expensive and much more slower (just imagine intranet web applications where you have to upload files to the server...just try that with Apple adapter) makes Apple adapter almost unusable.

    The excuses about driver that might be obsolete soon, is not good enough. Otherwise, we should never pick any device that is not made by Apple.
     
  23. sundragon, Jan 31, 2012
    Last edited by a moderator: Feb 11, 2012

    sundragon macrumors regular

    sundragon

    Joined:
    Dec 27, 2011
    Location:
    Washington, DC
    #23
  24. 87racer macrumors member

    87racer

    Joined:
    Nov 15, 2010
    Location:
    Oregon
    #24
    If you haven't already got this working, and it is in fact an asia chipset, the reason is the asix drivers are 32bit only and Lion boots into 64bit by default.

    The solution is to reboot and before you see the Apple logo hold 3 and 2 at the same time until you see the spinning wheel. This will boot you into 32bit mode and you can go to Network and it works.

    This is from experience with a Sabrent Adapter that uses the ASIX AX88178.
     
  25. Rayd5365, Feb 4, 2012
    Last edited by a moderator: Feb 11, 2012

    Rayd5365 macrumors member

    Joined:
    Aug 31, 2010
    #25
    As has also been said, the Apple adapter is 100Mbps.
    Also, yes the Gigabit adapter is limited by the fact that it is plugged into a USB 2.0 port, which gives it a maximum speed somewhere north of 400Mbps.
    Last I checked, 400Mbps is about 4x faster than 100Mbps.

    Does everyone need that speed? no
    Most of the time wifi is fine.
    But if you're moving big video files to/from your NAS or around your network, it can be handy to have this speed. The fact that this thing is 1/2 the price of the pretty white Apple adapter is just bonus.

    I just had to figure this out with my Monoprice branded adapter. Some pointers that may help:

    For me, the device would show up, it would connect, but it would not get a valid IP address via DHCP. - until I found and installed the correct drivers.

    First thing is to determine if you have the ASIX or the SMSC chipset.
    To do this, got to Utilities and System Information.
    Find the USB section and you should be able to spot the adapter in this list.
    Mine was the ASIX AX88178. This is the same chipset as "Plugable" branded one sold on Amazon.
    A quick search(elsewhere) led me to their website: http://www.asix.com.tw/
    From there, you can pretty quickly find the drivers download page.
    The readme file will show you that Lion support was added sometime in August.
    Install the driver, reboot, done. Works perfectly, and is fast.

    I can now attest from experience that large files copy to my NAS 2-3 times faster than with a 100Mbps ethernet adapter.
     

Share This Page