Cannot get my Tiger-upgraded ibook to work! I'm lost - Please help!

Discussion in 'PowerPC Macs' started by dot, May 11, 2009.

  1. dot macrumors newbie

    Joined:
    Nov 25, 2006
    #1
    Hello everyone!
    I have been inactive member and really don't know all that much about macs.
    But the idea of buying a gently used and good looking dual usb 2001 ibook (http://support.apple.com/kb/SP105) from a friend, upgrading it to Tiger seemed like a good challenge.

    I got more RAM (first one purchased was defective: not recognized, but second one worked fine), finally installed Tiger (Erase and Install) after running used disc (from e**y) more than dozen times but the computer kept crashing on me and started showing kernel panic. Apple hardware test didn't show anything wrong, so I went to Tekserve in NY to have it tested on the spot. The girl said their system shows there is something wrong, she said that it's probably hard drive crashing (that was what I was told by apply genius prior to that). I've installed 120 gb Hitachi drive, installed Tiger (again running it multiple times - install disc isn't in it's best shape) but was not able to install updates at all and pretty much every application quits on me "unexpectedly" within seconds. I can only browse Amazon to my knowledge. Apple websites are tricky: some I can look at with no problem, some do not show some images, and when I search for something on their site it shows me blank window in search results.
    I've run apple hardware test - everything passed ok & disk utility (using install disc and safe mode) many, many times - 1 problem: "volume HD could not be repaired". Recently with my friend's help I ran Disk Warrior 4.1 (T mode through macbook) and that fixed bunch of problems (went from 39% of damaged files to <1%). Right after diskwarrior disk utility showed no problems, but applications still quit on me. I've pramed my ibook, checked for troublesome fonts in my fontbook, repaired permissions, ran apple hardware test, tried to open in a safe mode, which didn't work. Then I tried typing the commands in Terminal, but ibook froze on me couple of times. Terminal didn't work with "sudo update_prebinding -root / -force -debug", showing "no such file or directory". I ran diskwarrior and this time it showed "incorrect number of thread records" and "invalid volume file count"(1 too many!) and eventually "volume HD could not be repaired". Disk Utility cannot fix it. Apple software update still quits on me either while dowloading or while installing updates (half way through).

    I REALLY would like to get it to work, but how? I should be able to use diskwarrior again in a couple of days, but I know that it will not let me work with anything. What else is wrong? I know it's an oldie, but I really would like to get it to work. I do have mac OS 9 install disc - should I say goodbye to Tiger and try to install os9 again? What could be wrong?

    You guys here are experts, PLEASE HELP!

    Sorry for such a long post but I don't want to leave anything out. I'm lost and not really sure what and how to go about my next step.

    Thanks in advance!
     
  2. molala macrumors 6502a

    Joined:
    Oct 25, 2008
    Location:
    Cambridge, UK
    #2
    All I can say is that I've had trouble getting Tiger to run on Macs of that age (PowerMac G4s, Powerbook G3s of 333 to 500 MHz, RAM ranging from 256MB to 1GB). I gave up troubleshooting them and just installed Panther, MacOS 10.3. It always worked.

    Good luck.
     
  3. Insulin Junkie macrumors 65816

    Insulin Junkie

    Joined:
    May 5, 2008
    Location:
    Mainland Europe
    #3
    Though according to quite a few posts around the net people have managed to install Tiger on their '01 iBooks just fine.
     
  4. dot thread starter macrumors newbie

    Joined:
    Nov 25, 2006
    #4
    An update:
    Ram turned out to be my problem, or rather its density. Despite all the hardware tests, disk utility, diskwarrior, etc. coming out clean. I downgraded the ram with a borrowed (lower density) chip and that worked like a charm. I'm exploring Tiger now :D.
    Thank you all.
     

Share This Page