Cannot get wi fi ' unable to join ' ?

Discussion in 'iPod touch' started by watfordpete, Aug 31, 2010.

  1. watfordpete macrumors newbie

    Aug 31, 2010

    I hope someone out there can help. I have an ipod touch and until recently I could connect to my wi fi, I am now getting nothing at all, when I try to join it is telling me that I am unable to join ? I have tried resetting the ipod and that does not work. I do know that the wi fi is working as other people can access the internet from it. Thanks in advance for any help given.

  2. battlekid macrumors regular

    Nov 23, 2009
    Somewhere in the middle of nowhere
    It's possible that your too far from the router. Move closer, you have too weak of a signal!:rolleyes:
  3. trsnrtr macrumors 6502


    Nov 21, 2009
    Central Illinois, USA
    I've been having this problems in motels lately. My laptop will connect but my Touch won't. It's getting frustrating.
  4. watfordpete thread starter macrumors newbie

    Aug 31, 2010
    Its not the router, I have tried getting a connection next to it but with no luck, others with the same ipod can connect from it without any problem at all ?

Share This Page