Cannot import my M4A files

Discussion in 'iPod' started by AppleMan940, Mar 11, 2010.

  1. AppleMan940 macrumors member

    Apr 8, 2009

    My library just got messed up. Badly. I opened iTunes today, bam, it was all blank. No worries. I deleted iTunes Library.xml and managed to select my library from iTunes.tmp. Unfortunately, it happened again so I lost it all.

    I am trying to import the folder "iTunes Music". I have around 500 songs. However only 400-ish import. I've noticed all the ones that import are MP3. Why don't my M4As import? I have recently moved to ripping discs to M4A, as they provide a better quality than MP3 at the same bitrate. Even if I go to Add File in iTunes they do not add. I've tried creating a new library, reinstalling iTunes no luck.

    Any ideas? These m4as are ripped from CDs so they should be DRM free?

    Thanks a lot!
  2. GGJstudios macrumors Westmere


    May 16, 2008
  3. AppleMan940 thread starter macrumors member

    Apr 8, 2009
    I know I can convert these. But I don't want to. I want my audio to work like it did before. It worked in iTunes before why won't it now?
  4. AppleMan940 thread starter macrumors member

    Apr 8, 2009
    Thanks for your help but still no luck, tried everything.

Share This Page