Resolved cannot install 10.11 from external drive: Volume contains an OS X installation which may be damaged.

Discussion in 'macOS' started by Thijs Moonen, Mar 13, 2016.

  1. Thijs Moonen macrumors member

    Joined:
    Aug 22, 2011
    #1
    Hello everyone, thanks for your help.

    I am trying to install 10.11 on a 2011 13" Macbook Pro. It was running 10.6 perfectly.

    - I upgraded to 10.11 as a test. No problem. Now I wanted a clean install. All data on the 2011 MBP had recently been transferred to a new device. So:
    - I created a bootable external drive with the OS X 10.11 installer
    - I booted the MBP from the external drive. I ran Disk Utility and erased the MBP's internal HD [OS X Extended (Journaled), GUID Partition Map]
    - I run the installer and get an error that says (see picture):

    OS X could not be installed on your computer

    Volume contains an OS X installation which may be damaged.

    Quit the installer to restart your computer and try again.

    - I tried erasing the internal HD again
    - I ran First Aid on the internal HD, no errors
    - I partitioned the internal HD and ran the installer - can't choose a partition to install on, same error

    I have no idea what's going on and I'd appreciate any leads. Thanks!

    http://imgur.com/feLDU4J
     
  2. CoastalOR macrumors 68000

    CoastalOR

    Joined:
    Jan 19, 2015
    Location:
    Oregon, USA
  3. DeltaMac macrumors 604

    DeltaMac

    Joined:
    Jul 30, 2003
    Location:
    Delaware
    #3
    There's an additional reason to redownload the full installer app.
    You will get the most recent released version (today would be version 10.11.3)
     
  4. BLUEDOG314 macrumors member

    BLUEDOG314

    Joined:
    Dec 12, 2015
    #4
    You can also resolve this by changing system time in terminal so that it has the right date. Even easier, when you go into installer, connect to wifi or ethernet so it can set the time properly on its own.

    Hopefully you don't run into the noto issue. As of late I haven't been able to do what you are trying to do because the installer gets to literally one second remaining and gets stuck. Reading the log shows its trying to unpack noto fonts and gets stuck in some kind of loop. The log file will literally get to 10s of thousands of lines. I have tried to get the noto fonts from Google for free and manually insert them into the installer before making it bootable, but so far no luck.

    If you have this issue or not I would be curious to know how it goes.
     
  5. DeltaMac macrumors 604

    DeltaMac

    Joined:
    Jul 30, 2003
    Location:
    Delaware
    #5
    bluedog, I suggest that you try to wait that out. I have two identical minis, except that one has an SSD, and the other has a spinning hard drive. The hard drive takes a great deal longer to install El Capitan
    SSD - about 25 minutes total. The hard drive mini takes more than 90 minutes, and seems to hang on that last minute for the majority of that time.
    Find something else to do for an hour or two. I bet you will come back to find that it has finished the install.
     
  6. Fishrrman macrumors G3

    Joined:
    Feb 20, 2009
    #6
    OP:

    Here's what I'd suggest you do.

    You have already created a new, fresh clean bootable copy of 10.11 on the external drive.
    Is this correct?

    If so, download CarbonCopyCloner from:
    http://www.bombich.com/download.html
    CCC is FREE to download, and it's FREE to use for the first 30 days.

    Put CCC on your new external bootable copy of the OS.

    Now, launch CCC.
    For the "source" (on the left) select the 10.11 external boot drive (that you're booted from already).
    For the "target" (on the right) select your internal drive (which is initialized and empty).
    ALSO -- in CCC prefs, make sure it's set to clone the recovery partition as well (very useful feature).

    Then, let CCC do its thing.
    It will copy the clean install of 10.11 over to the internal drive.

    When done, shut everything down, and disconnect the external drive.

    Now, do a reboot, and hold down the option key until the startup manager appears.

    Select the internal drive (probably only choice) and hit return.

    DO YOU GET A GOOD BOOT?
    If so, look around to be sure everything is as you like it.

    Next, open System Preferences, click the Startup Disk pane, and re-select the internal drive to be the boot drive. Sometimes "Startup Disk" forgets.

    If you follow these instructions, I think your problems will be solved.
    Good luck!
     
  7. Thijs Moonen thread starter macrumors member

    Joined:
    Aug 22, 2011
    #7
    Hello CoastalOR, DeltaMac, BLUEDOG314, and Fishrrman.

    Thank you all for your great suggestions. It seems that the problem was indeed caused by an expired installer.

    I booted the MBP from the external drive, and ran terminal from the menu bar.

    Then I entered the command
    Code:
    date 0201010116
    and rebooted. The installer is now running and I will update to the most recent release once that's done. If I do still run into any trouble I'll let you know.

    Thanks again for taking the time to help me out!
     
  8. komatsu macrumors 6502

    Joined:
    Sep 19, 2010
    #8
    I never knew that Installer checks date again the system clock?
     

Share This Page