Cannot install graphics drivers in Windows EFI

Discussion in 'Windows, Linux & Others on the Mac' started by Jazzyjester, Jan 26, 2015.

  1. Jazzyjester macrumors newbie

    Joined:
    Jan 26, 2015
    #1
    Hi, I created an account specifically for this problem because its been frustrating me to no end. I apologize in advance if this is a long post. I recently followed this guide (http://www.reddit.com/r/mac/comments/2fy3be/by_popular_demand_my_better_than_bootcamp_guide/) to installing Windows in EFI mode on my Macbook Pro (non-retina) 2012 model with Intel 4000 HD integrated graphics card and Nvidia GT 650m dedicated graphics card. I made a bootable ISO using the Windows usb tool (Windows 8.1 Pro EFI) and downloaded the bootcamp drivers straight from the Apple support website (version 5.1.5621) and put it on the flash drive as well. The actual windows install went smoothly and I had no problems there. It's when I tried to install the Bootcamp drivers is when things started to go downhill. When launching the setup from the original 5.1.5621 bootcamp the setup would stop at installing the nvidia install and the screen would suddenly go black and would stay like that even after a restart (the comp would restart then suddenly go black once it boots into Windows). Looking online I found out some people had trouble with the latest bootcamp version and installed an earlier version (5.0.5033) and got that to work. So I reinstalled Windows and tried installing the Bootcamp drivers from version 5.0.5033, and the setup would just skip the nvidia driver install and would give me the blue screen of death when trying to install the Intel HD driver. Next I tried installing the drivers straight from nvidia and Intel, but both of those drivers gave me the same problems the bootcamp drivers game me (black screen for nvidia, crash blue screen of death for intel and restart/crash loop). I went to the device manager and saw that under display adapters, only Microsoft Basic display adapters are listed where both Intel HD 4000 and nvidia gt 650m are suppose to be listed. Trying to put the actual drivers on my desktop and update using device manager yielded the same results. I also tried just deleting the basic adapter drivers and just installing the intel/nvidia drivers, but then both installers for intel/nvidia said that no supported hardware was found. So I'm turning to you guys to see if you can help me before I give up on installing Windows on my mac altogether.
     
  2. yjchua95 macrumors 604

    Joined:
    Apr 23, 2011
    Location:
    GVA, KUL, MEL (current), ZQN
    #2
    This is what I did to get Windows running in UEFI perfectly, over USB 3. All drivers installed perfectly (GT 750M in my 15" rMBP).

    Connect external drive to Windows VM. You must have a Windows VM in VMware/Parallels/VBox, or a Windows PC. Any existing Windows environment will do.

    What you need:
    install.wim file (obtain this from your Windows ISO)

    Open elevated cmd.exe (run as admin)

    Note: All commands aren't case sensitive, including pathway to files.

    Type diskpart
    Type list disk
    Take note of the disk you want to select
    Type select disk 1 (if your disk is Disk 1)
    Type clean
    Type convert gpt
    Type create partition EFI size=100
    Type format quick fs=fat32 label=EFI
    Type assign letter=S
    Type create partition primary
    Type format fs=ntfs quick label=W2G (or any other name you wish for label)
    Type assign letter=E
    Type exit

    Open up File Explorer. In your C drive, create a new folder named WIN2GO.
    Put the install.wim file in this folder

    Back in cmd.exe:
    Type dism /apply-image /imagefile:C:\WIN2GO\install.wim /index:1 /applydir:E:\ (this process will take quite a while)
    Type E:\Windows\System32\bcdboot E:\Windows /s S: /f UEFI

    Restart your entire Mac. After the chime, hold down Option and when prompted to select your boot drive, select EFI Boot.

    Proceed installation normally.

    After installation, install Boot Camp drivers. Feel free to trash the VM once you're done too.

    For best results, use USB 3/Thunderbolt. If you don't have USB 3, use Thunderbolt. If you have neither, stick back to the internal drive :)

    You can also try to do it on the internal drive, but it requires:
    1. An external drive holding the install.wim file
    2. A bootable Windows 8.1 stick
    3. Some modifications of the commands (namely the file locations)
    4. A Time Machine backup of your OS X side, because it involves erasing the entire drive.
     
  3. sphere2k macrumors newbie

    Joined:
    Jan 31, 2015
    #3
    Same here with a Mid-2012 MacBook Air (Intel HD graphics only). Intel graphics drivers seem to be the root of the problem. Windows installs without any issues in EFI mode, but as soon as I try to replace the generic graphics drivers with Intel's drivers, the screen will go black (although windows doesn't crash -- it's still running and can be reached via RDP); doesn't matter which driver version I use: the one from the BootCamp package or the most recent one from the Intel website.
     
  4. whiteonline macrumors 6502

    whiteonline

    Joined:
    Aug 19, 2011
    Location:
    California, USA
    #4
    I don't think all the workarounds are necessary anymore.

    To install the Win10 preview:
    - Use bootcamp assistant to create the media and partition
    - Reboot, hold option. Select the EFI boot option, not Windows.
    - When you get to the partition selection, delete the created bootcamp partition.
    - Select the now-free space, and install. No need to format.

    Easy peasy.
     
  5. WSChurchill macrumors newbie

    Joined:
    Jun 12, 2015
    #5
    I too created this account simply to bump this thread.

    I am running a early 2011 MBP i7 with the AMD HD 6750M. I have had BootCamp working fine at some point in the past but it's hates the latest bootcamp from Apple (5.1) and won't accept most of the old ones either. The Intel drivers simply turn my screen black and the AMD drivers regardless of whether I am using the latest or some hack legacy ones still is unable to "locate hardware". I am usually very persistent and resolved to do this on my own but getting to my wit's end here. It's one thing for vendors to maintain support despite little incentive but Apple clearly states the drivers are 100% compatible and should work with our devices...
     
  6. saturnotaku macrumors 68000

    Joined:
    Mar 4, 2013
    #6
    The Intel GPU is not active when installing Windows via Boot Camp, and UEFI is not supported on your machine.
     
  7. yjchua95 macrumors 604

    Joined:
    Apr 23, 2011
    Location:
    GVA, KUL, MEL (current), ZQN
    #7
    Only Macs that are Haswell or later support UEFI. Earlier Macs do not have a UEFI-2.0 compliant chip in the logic board.
     
  8. sg333 macrumors newbie

    Joined:
    Jul 5, 2017
    #8
    Here is solution!
    I got similar issue on my MBA mid 2011 - black screen after intel HD drivers installation. (you can still get it work without drivers by disabling drivers when booted in to windows safe mode)
    This happens because of EFi installation. On all Macs before 2013 EFI installation should be avoided as mentioned above UEFI 2.0 is not supported.

    Solution: Use bootcamp to create installation media (if your Boot Camp won't allow to use windows 10 on your Mac add your Mac model to info.plist Boot Camp file)

    Always choose Windows not EFI in boatmenu on all Macs before 2013.

    Hope it will work for you!
     
  9. ActionableMango macrumors 604

    ActionableMango

    Joined:
    Sep 21, 2010
    #9
    These blanket statements are not true. Windows 8.1 EFI and Windows 10 EFI works fine on 2009 and 2010 Mac Pros for example, which are Nehalem and Westmere CPUs (many generations prior to Haswell) and neither of which have EFI 2.0.
     

Share This Page