Cannot install Steam :(

Discussion in 'Mac and PC Games' started by TDHXXX, Nov 30, 2010.

  1. TDHXXX macrumors regular

    Jul 3, 2009
    i just got my new imac (21.5" i5) and downloaded steam, dragged the file into the applications folder and it starts the first update (downloading ~34mb), it reaches 24 and then fails with a 'steam needs to be online to update' message, clicking ok closes the app and i get nowhere!

    i have tried this three times each failed, i had steam installed on my old iMac (27" i7)with no worries.

    any one know whats up?

    i've emailed steam support but their only suggestion is to reinstall steam (but i can't install it in the first place. :mad: )
  2. Hansr macrumors 6502a

    Apr 1, 2007
    Tried restarting the computer and/or router? Sounds like a network issue.
  3. TDHXXX thread starter macrumors regular

    Jul 3, 2009
    Yeah, tried that, I've been trying to get it to install for the last 2-3 weeks. :(
  4. Hansr macrumors 6502a

    Apr 1, 2007
    Delete Stream prefs and application support etc and see if that works.
  5. TDHXXX thread starter macrumors regular

    Jul 3, 2009
    It might... if I had those files to begin with. :(
  6. Hansr macrumors 6502a

    Apr 1, 2007
    They should be created the first time you launch the app and it goes into self update. If they aren't created you have a permission problem on your machine.

    Quickly try creating a new admin account and installing it there.
  7. lordjonny macrumors regular


    Sep 18, 2006
    does sound like a permission's issue, open up "disk utility" and click "repair disk permissions" see if that fixes it...
  8. CylonGlitch macrumors 68030


    Jul 7, 2009
    PM "rbarris" here on the forums. He is busy, but a good guy and if anyone can solve the problem it would be him.

    BUT I would exhaust all other options first.
  9. rien333 macrumors regular

    Jun 29, 2010
    The Netherlands
    I had the exact same problem for about 2 weeks and I know how irritating it is. (I just got a new internet connection 2 days ago and no problems anymore)
    Maybe you will find a more cheap solution in this link:

    It did help for me, but the problem might come back.

Share This Page