Cannot jailbreak iPhone 3G on 4.0.1

Discussion in 'Jailbreaks and iOS Hacks' started by LongbowFoSho, Nov 26, 2010.

  1. LongbowFoSho macrumors member

    Joined:
    Nov 26, 2010
    #1
    This is my first post on here, so......hi.

    First, I'm not a noob jailbreaker. I'm not an expert by any means, but I know enough to do what I need to do (usually, LOL). I've jailbroken at least a dozen phones over the last week alone, so its not my first time. :cool:

    My problem: I have three different 3G iPhones that are all on 4.0.1 that I can't jailbreak, no matter how hard I try.

    Jailbreakme gives me the "file received was invalid" error every time I try to jailbreak. Every. Single. Effin. Time. I've tried clearing the Safari cache, cookies, history, everything. No dice.

    I even tried downgrading to 4.0, but no dice.

    Is there something wrong with Jailbreakme lately that I don't know about? I've done dozens of jailbreaks with it before, but suddenly its not working.

    I've also tried redsn0w, but it gives me the "unable to recognize specified IPSW" every time I select the firmware.

    Any ideas? :confused:
     
  2. PsstGreek macrumors 68040

    PsstGreek

    Joined:
    Oct 21, 2010
    Location:
    Tampa Bay
    #2

    A lot of people are having problems with using jailbreakme.com (maybe @comex took it down).

    When you use Redsn0w you need a 4.0 ipsw. Redsn0w recognizes 4.0 only (4.0/4.0.1/4.0.2 are the same essentially)
     
  3. LongbowFoSho thread starter macrumors member

    Joined:
    Nov 26, 2010
    #3
    So I need a vanilla 4.0 IPSW, or will 4.0.1 suffice for Redsn0w?

    Thanks for the quick response.
     
  4. PsstGreek macrumors 68040

    PsstGreek

    Joined:
    Oct 21, 2010
    Location:
    Tampa Bay
    #4
    You'll need a 4.0 ipsw for Redsn0w to jailbreak on 4.0.1
     
  5. LongbowFoSho thread starter macrumors member

    Joined:
    Nov 26, 2010
  6. LongbowFoSho, Nov 26, 2010
    Last edited: Nov 26, 2010

    LongbowFoSho thread starter macrumors member

    Joined:
    Nov 26, 2010
    #6
    Well, redsn0w still says it can't recognize the IPSW. FML.

    In fact, it will only recognize 4.1 or 4.2. Anything else fails every time.
     
  7. PsstGreek macrumors 68040

    PsstGreek

    Joined:
    Oct 21, 2010
    Location:
    Tampa Bay
  8. LongbowFoSho, Nov 26, 2010
    Last edited: Nov 26, 2010

    LongbowFoSho thread starter macrumors member

    Joined:
    Nov 26, 2010
    #8
    Hmmm.....I actually had 0.9.5b5-2, so I'll try that.

    Would 0.9.5b5-5 be compatible? That's what comes up in your link.
     
  9. PsstGreek macrumors 68040

    PsstGreek

    Joined:
    Oct 21, 2010
    Location:
    Tampa Bay
    #9
    Make sure you have the right ipsw --> iPhone1,2_4.0_8A293
     
  10. LongbowFoSho thread starter macrumors member

    Joined:
    Nov 26, 2010
    #10
    Well, 5-5 recognizes 4.0, but not 4.0.1. The problem is, the phone is on 4.0.1 and I really don't know if its worth it to take the time to downgrade it to 4.0, only for redsn02 to give me the finger and fail to recognize the 4.0 file, LOL.

    EDIT: SUCCESS! Its jailbreaking as we speak. Thanks for all the help, dude. I'll be sure to let you know if something else retarded comes up before I'm done, LOL.
     
  11. PsstGreek macrumors 68040

    PsstGreek

    Joined:
    Oct 21, 2010
    Location:
    Tampa Bay
    #11
    Oh no you don't need to downgrade the iPhone to 4.0. Because there was no significant change from 4.0-4.0.2, Redsn0w thinks your iPhone is on 4.0, so it will jailbreak.

    That's why you need the 4.0 ipsw.
     
  12. LongbowFoSho thread starter macrumors member

    Joined:
    Nov 26, 2010
    #12
    Well, they are all now successfully jailbroken and unlocked. Thanks again for the help!
     
  13. PsstGreek macrumors 68040

    PsstGreek

    Joined:
    Oct 21, 2010
    Location:
    Tampa Bay
    #13
    Good to here. No problem:apple:
     

Share This Page