Cannot left click, Only right click is available.

Discussion in 'macOS' started by ksc1213, May 2, 2010.

  1. ksc1213 macrumors newbie

    Joined:
    May 2, 2010
    #1
    I use MacBook Pro 15' with OS X 10.6.3.

    Today, I found that I cannot do left clicking after I switched user accounts from one to another. Whenever I click my mouse or one fingered click on trackpad, context menu for the area is poped up. Simply, I cannot click or double click anything. And same time, my keyboard is malfunctioning too. When I type anything, nothing is appeared in the monitor or some other letters those I did not typed are appeared.

    When I log in with other user account, I have no problem in the environment. But When I log out and log in again with a certain account, that is my main account, the same trouble is still exist.

    I did bellows :

    - Rebooted more than several times.
    - Reinstalled OS X.
    - Push and hold Cmd + alt + r + p while booting. (several times. But could not separated my battery because it is not allowed.)

    Nothing above could solve the problem yet.

    Any ideas or Advices?
     
  2. rdowns macrumors Penryn

    rdowns

    Joined:
    Jul 11, 2003
    #2
    Go into the mouse control panel and set left click as primary mouse button.
     
  3. cherry su macrumors 65816

    cherry su

    Joined:
    Feb 28, 2008
  4. ksc1213 thread starter macrumors newbie

    Joined:
    May 2, 2010
    #4
    Thank you but...

    Thank you for your advice. But I cannot find menu for setting primary mouse button. I am using magic mouse and trackpad and checked both control panels
    to find out the menu but could not.

    And above advice does not explains why my keyboard is not answering.
     
  5. Hellhammer Moderator

    Hellhammer

    Staff Member

    Joined:
    Dec 10, 2008
    Location:
    Finland
    #5
    Repair permissions with Disk Utility and reset PRAM and SMC
     
  6. ksc1213 thread starter macrumors newbie

    Joined:
    May 2, 2010
    #6
    How?

    Thank you for your advice but I did reinstalling os x and all software update after the trouble showed up. Any other things I am still missing?
     
  7. ksc1213 thread starter macrumors newbie

    Joined:
    May 2, 2010
    #7
    I tried..

    Thank your for your advice. I followed your advice but it could not solve my problem. As I wrote before, only my major user account has these problem.
    If I log in as other user, it just works fine. It make me consider that the problem is caused by more higher layer than hardware or firmware.

    I am still wondering and any other advice will be appreciated.
     
  8. Ice Cream Man macrumors member

    Ice Cream Man

    Joined:
    Jan 1, 2003
    Location:
    Earth
    #8
    If it's account specific then reinstalling OSX over OSX isn't going to lift the problem as it sound like either a preference setting, or some other program is 'grabbing' controle of that function.

    I thought gestures worked on the Magic Mouse(as i don't have one) can't you just double tap(two fingers at once) to right click?
     
  9. Ice Cream Man macrumors member

    Ice Cream Man

    Joined:
    Jan 1, 2003
    Location:
    Earth
    #9
    Also have you tried just holding the Control key and left clicking, (the old way) to get right click? Just to make sure it's not something inhibiting right click all together.
     
  10. ksc1213 thread starter macrumors newbie

    Joined:
    May 2, 2010
    #10
    I disabled magic mouse and am using trackpad only. Using magic mouse did not show any difference to me.

    The problem is no more account specific. My another account shows me same problem now. But when I restarted my MacBook Pro, it seems ok in the account, but time to time it shows the problem and if the problem occurs once, it keeps me out of control until I reboot it.

    It seems like someone is keeping to hold ctl key in my keyboard. I tried ctl + click but there was no change. When the problem start to occur, I can do nothing but reboot.

    As you wrote, I feel like some other program is stealing my input to mac and it begins with some condition. But I don't know what it is and how it can be started. This situation started to happen just yesterday and as far as I remember I did nothing unusual except switching a user account once.

    I am considering to visit genius bar today, but I don't want to remain my mac to them more than a week. It's horrible especially this week!
     
  11. chairguru22 macrumors 6502a

    Joined:
    May 31, 2006
    Location:
    PA
    #11
    I just started having similar issues with my MacBook 10.6.3 (older model with seperate trackpad button) and I haven't figured out a fix. I also restarted a lot and repaired permissions and repaired the hard disk from the install disc. Messing with system preferences didn't help. I also only have one user account.

    My trackpad doesn't allow button or touch clicking. When using a USB (haven't tried BT yet) mouse it only allows right clicking. It sometimes, after a restart, will function normally with a USB mouse but when I move the cursor with the trackpad the problem reappears... the keyboard appears to still function normally.

    I will try to schedule a genius visit if i can't figure this out but I fear they will just say the logic board needs replacement and that will be $500+ for a 4 year old OOW computer. I might as well spring for a MBP which might not be a bad idea with the back-to-school, iPod giveaway/free printer deal coming soon.

    any other thoughts?
     
  12. edatmpa macrumors newbie

    Joined:
    May 11, 2010
    #12
    Left click does not work on either BT mouse or pad

    I had the same puzzling condition. It turns out I had 2 BT mouses connected at the same time. One was on in my carrying case and one I was using on the desk. The result was: no left click! Turning off one of them solved the problem. A quick check is to close the lid of the macbook. Upon opening the left click on the pad will work briefly, few seconds, before the BT get reconnected.
     
  13. privatepile macrumors newbie

    Joined:
    May 19, 2010
    #13
    edatmpa you are a genius!!!

    Ok, edatmpa totally solved my problem. For some puzzling reason today, my left click started to not work. As you can imagine, this make your computer useless. I got a magic mouse with my imac, but don't like to use it so I have a normal kensington mouse. Somehow, my magic mouse ended up in the vicinity of my computer (probably my kids) and caused my left click to not work. It was shoved behind my printer so maybe it was being clicked...and canceled my kensington. So make sure that you don't have your magic mouse and another mouse connected at the same time. I may never have figured out this solution...thanks edatmpa!!!!
     
  14. silby101 macrumors member

    Joined:
    Jun 20, 2003
    #14
    Using VNC also causes this problem

    I was using VNC into my Mac Pro 2010, running 10.6.5, and when I tried to click on anything, only right click was working, and my left click was registering as right click. Keyboard was also non-responsive. Rebooting the Mac Pro fixed the problem, but it was super frustrating trying to fix this. Apple should be made aware.
     
  15. tidalwav1 macrumors newbie

    Joined:
    Aug 7, 2010
    #15
    Thank you thank you thank you! Had a Magic Mouse in my bag that had somehow switched on inside the bag and was probably positioned so that the button was held down, so I couldn't left click. Turning off Bluetooth got me back in business. I had been totally stumped until I saw your post. :)
     
  16. skkeptickle macrumors newbie

    Joined:
    Dec 26, 2012
    #16
    doh!

    For me it was that I had a touchpad under some papers on my desk which slowly grew higher until it was activating the left click and freezing same on my magic mouse. Doh! Thanks
     
  17. shaz13 macrumors newbie

    Joined:
    Feb 10, 2011
    Location:
    Koh Samui, Thailand
    #17
    no left click

    I'd be interested to know how/if you managed to fix this issue. My 2006 Macbook black has today stopped left clicking and only occasionally will it right click. Neither the trackpad, click bar or USB mouse will work.

    Any help gratefully received:)
     
  18. chairguru22 macrumors 6502a

    Joined:
    May 31, 2006
    Location:
    PA
    #18
    Wow! Old thread! But yea, I did end up getting a new MBP anyway and don't really use my old MacBook anymore. Not sure if the issue still exists or not. Can't remember what happened, so long ago..

    Could be a setting got changed, or possibly a BT mouse is connected that shouldn't be.
     
  19. alcomputer1 macrumors newbie

    Joined:
    Jun 9, 2013
    #19
    I have an i mac. I use a trackpad and a mouse both are connected at once. On starting it I found that the left mouse button did not work on either device but everything else did. I looked in the forums for similar problems and the solution, i then realized from the replies that it appeared in my case to be a problem with the trackpad, so I removed the batteries from the trackpad and lo and behold problem solved.
     
  20. Kali-in-SoCali macrumors newbie

    Joined:
    Jun 18, 2013
    #20
    It's the Bluetooth

    I had the same problem. Apparently if you have another computer that uses another Bluetooth mouse, you will get this problem. The disk permissions repair will fix the keyboard Bluetooth connection.

    The only solution I found: turn off BLUETOOTH This will allow your left click to work again.
     
  21. markus22 macrumors newbie

    Joined:
    Aug 26, 2013
    #21
    right click solved or rather my own stupidity solved

    I had the same problem. Left and right clicks registering as right clicks. Infuriating!!
    It turned out to be something quite silly.
    I had a bluetooth keyboard that I didn't realise was connected. It was sitting somewhere in my house ina pile of things. Something was depressing the ctrl key causing all clicks to register as right clicks.
    While this is unlikely to be a common cause of the problem, it may suggest that the fault some of you are having is with your ctrl key being activated by accident. Perhaps it is stuck down because of dirt on the keyboard or something.
    Just a thought. Good luck.
     
  22. Darquer macrumors newbie

    Joined:
    May 5, 2014
    #22
    Still an issue in 2014 - But this solved it

    This happened to me for the first time tonight. I just got home from a weekend away and I could not left-click with the trackpad or an external mouse. I searched for a solution after trying several things myself. When I read this, I thought to myself that I don't have a BT mouse that is on or that I have used with this Macbook Air for many months.

    I was able to work with the bluetooth menu with right-click on the trackpad and to my surprise, saw a BT mouse connected with 65% battery life. I then remembered having pulled my Magic Mouse out of my notebook bag when I was packing for the trip. I looked and wow, the mouse was on. This mouse has been on and in that notebook bag for several months. I am amazed that the battery is still at 65%. I turned the mouse off and my left-click issue is resolved.

    It's amazing to me that this is a known issue for years and has not been resolved. I should be able to use my left click whether a bluetooth mouse is connected or not.

    Thank you to @edatmpa for posting the solution. It still helps four years later.
     
  23. EXTRSD macrumors newbie

    Joined:
    Dec 28, 2014
    #23
    Macbooks

    If this issue is occurring for you on a macbook and you only have the trackpad input (no external mice or trackpads), it could be that your laptops battery is expanding and pushing up on the trackpad from below. This kind of expansion can be caused by excessive heat or age, most batteries tend not to live past 2 years, let alone 3.

    To test for this check to see if you can depress the trackpad. The lower left and right corners depress between ~1-3mm. If your right button still works you can test it with the other corner, if not test it at a mac store to compare.

    The batteries are kind of expensive, but if you buy the Apple ones and take care of it, they are easily the longest lasting laptop batteries I have encountered.

    Source: Ex Retail and Service employee for a computer store.
     
  24. chaley10 macrumors newbie

    Joined:
    Apr 4, 2015
    #24
    Change the batteries in your mouse

    I had the same problem and it ended up being my mouse that was causing the issue. I shutdown my computer and turned off my mouse and the track board worked fine on reboot. Could move cursor and left click. Then I turned on the mouse and the left click didn't work on my mouse OR track board. Not sure how that happens, but it did. I replaced the batteries in the mouse and now everything is working fine. Hope this helps....
     
  25. GettingThere.. macrumors newbie

    Joined:
    Nov 25, 2015
    Location:
    UK
    #25
    Hi All, Just been looking through the forum as I had a problem where I was unable to left click with my Magic Trackpad and I keep finding references to multiple Bluetooth devices etc. My problem only affected certain applications, for example Contacts or iMessage (Apple Applications) but didn't affect the Virtual Machines I have running in Virtualbox. After lots of searching through settings and unplugging every USB device and moving all Bluetooth devices away (or turning them off) I noticed that Inking had become enabled, I switched this off and hey presto my left click began to work again. Hope this helps anyone who is still having issues...
     

Share This Page