Cannot log in after update to 10.12.3

Discussion in 'macOS Sierra (10.12)' started by t4ggs, Jan 24, 2017.

  1. t4ggs macrumors member

    Joined:
    Jul 9, 2010
    #1
    Hi, after yesterday's update (macOS 10.12.3) I cannot longer log in into my mac.



    First of all, everything was running smooth on my Mac. Last time it was restarted was around 40 days ago, I went out on a quick vacation so it entered sleep mode for around a week. Other than that, normal use, no issues.



    Yesterday I went to the App Store to install the OS latest version, after that it restarted as normal but stayed on a black screen and from time to time this image would appear and lasted only for a second or 2, so most of the time the screen is completely dark with no cursor or anything else.



    [​IMG]



    After some 20 minutes I understood that something happened and restarted the Mac. Everything went on as normal, booted up, arrived to the login screen (I only have one admin user with filevault on) and entered my password. Pressed enter and then the same symptoms: A black screen with nothing else and from time to time I see that wheel in the image above but only for a second or 2.





    I decided to try to boot on verbose mode (read that on the internet). Reached the login screen, entered my password and the last message I got was: "HID: Legacy shim 2".



    Any idea?



    Thanks, I'm going crazy, this is the first time I have such a big problem with my Mac and no idea on how to fix it.
     
  2. keysofanxiety macrumors 604

    keysofanxiety

    Joined:
    Nov 23, 2011
    #2
    I had a similar issue on a client's machine. The fix was booting into a USB stick which had OS X on, then deleted the com.apple.loginwindow.plist file located in Macintosh HD> Library> Preferences. It's slightly different in your situation as there wasn't that spinning logo and just a cursor instead, but I'm confident that it'll fix the issue. Even if it doesn't, it won't do any real harm as OS X will create that plist file again on login.

    If you don't have a USB stick with OS X on, you can hold CMD+R on startup to boot into OS X Utilities, plug in a USB stick, format the stick through Disk Utility, then select 'Install Mac OS X' to that USB stick. A bit lengthy but you'll always have that for diagnostic purposes in the future.

    Alternatively if there's any way you can boot through Target Disk Mode, or if you're comfortable deleting that file through Single User Mode, that should hopefully do the trick.
     
  3. t4ggs thread starter macrumors member

    Joined:
    Jul 9, 2010
    #3
    Deleted the file but it didn't work. Any other idea?
    --- Post Merged, Jan 24, 2017 ---
    Could not log in in safe mode either, same symptoms.
    Booted to recovery partition, reinstalled the OS but still the same issue!!
     
  4. keysofanxiety macrumors 604

    keysofanxiety

    Joined:
    Nov 23, 2011
    #4
    Hi there,

    I'm really sorry to hear that didn't do the trick. Please could you try to reset both the PRAM and SMC? Any luck there?
     
  5. t4ggs thread starter macrumors member

    Joined:
    Jul 9, 2010
    #5
    Neither worked. I went to recovery mode, used time machine to restore to an early date and got the same screen even before logging in.
     
  6. Fishrrman macrumors G4

    Fishrrman

    Joined:
    Feb 20, 2009
  7. t4ggs thread starter macrumors member

    Joined:
    Jul 9, 2010
    #7
    I tried a safe boot (pressing shift) but I reached the same you reach when entering recovery mode (cmd+r)...no idea why...
     
  8. t4ggs thread starter macrumors member

    Joined:
    Jul 9, 2010
    #8
    I formatted the disk, started with a fresh MacOS installation and everything worked fine so I proceeded to use migration assistant to restore from time machine.
    That solved the issue
     

Share This Page