Cannot log in iMac G5 Unix 10.5

Discussion in 'PowerPC Macs' started by gowguy, Jan 29, 2011.

  1. gowguy macrumors newbie

    Jan 14, 2011
    My passwords don't work to login. I've tried creating new accounts but the passwords don't work for those. Anyone with an idea of what could have possibly gone wrong?

    Not connected to internet, wireless, AirPort or Blue Tooth. Installed upgrades to VLC and Quicktime from a USB (no virus on it), and those went well. iTunes upgrade attempt from v.7 to v.10.1.1 crashed. It required my password then crashed.

    I've created several new accounts using the Install CD. They won't login. Verified disk, disk permissions, reset disk permissions, tried through Terminal to us fsck, no problems with the Hard Drive. Used Terminal to set new account. Won't work. I don't know Terminal at all so I've really limited what I look at or try.

    Cannot find my user accounts although I did once in Terminal.

    I live in Asia and cannot find very trustworthy techs here. Can anyone help? I have looked into Archive and Install. Does anyone know if that will work? I really need to get into my accounts.

  2. simsaladimbamba

    Nov 28, 2010
    Have you tried resetting the password(s)?

    Mac OS X: Changing or resetting an account password

    Btw, there are no viruses for Mac OS X:
    And what do you mean with?

    Mac OS X: About the Archive and Install feature:
    Btw, the OS is called "Mac OS X 10.5 Leopard", not Unix, though the "X" in "Mac OS X" is there to show the relation to Unix.
  3. gowguy thread starter macrumors newbie

    Jan 14, 2011
    "Can't login" response to help posts

    Hi and thanks for your replies. I'm replying to each post here.

    First, yes I have tried resetting the passwords. Several times. Write each one down and none of them have worked.

    Two. What do I mean with "installed upgrades to VLC and Quicktime?"
    I go to internet cafes here in Asia. I downloaded the latest upgrade to VLC from their site (, and upgrades to Quicktime and iTunes from the Apple site, leaving my email as they asked. The upgrade installs of VLC and Quicktime went fine, with restarts, and both worked well. The iTunes was an attempt to go from version 7 to version 10.1.1 and asked for my password. Then the install crashed. I tried it again with the same result, then decided the jump was too large, shutdown and went back to the internet cafe to get versions 8 & 9 and when I booted back up, the logins wouldn't work. The blue login button barely moves when I click it whereas it used to recoil very visibly.

    By the way, the USB was clean, no viruses on it and I only moved those upgrades to my desktop, disconnected the USB and did the installs.

    No one has access to my computer but I set it up for a login window that requires typing in a User name and then the password. This time when I booted I noticed a User name there under the Apple Logo and that was not correct.

    Third, I say Unix because of the newer Macs that are Intel? I use Tor sometimes because this place blocks more sites than anywhere in the world and new versions of Tor are distinguished to some degree by a Unix or Intel environment. Or so Tor has told me. :)

    Since I posted this, I tried another way (2 actually), of creating a new account with Terminal and the new passwords it seems, don't work. I get this message when finishing the password confirm in Terminal:

    passwd: DS error: eServerSendError
    <dscl_cmd> DS Error: -14740 (eServerSendError)

    Also, after typing in a new password and confirming it I get this:
    Unable to change password for record "myshortusername". eServerSendError

    I really appreciate your responses as it feels so alone here and finding a good tech who knows Mac and Terminal is nigh on impossible. I am holding back my panic as I really need to get into my accounts.

  4. simsaladimbamba

    Nov 28, 2010
    Have you tried the ROOT user yet?

    Btw, UNIX is the name of an Operating System (OS) developed in the late 80s, on which Mac OS X is based upon, thus the "X" in Mac OS X.
    Intel is a company developing and manufacturing CPUs (and other stuff) and Apple has switched to Intel CPUs in 2006 (announced in 2005). Before that Apple used IBM CPUs, called "PPC" or "PowerPC" CPUs and each generation had a name like "G3", "G4" or "G5".

    In short, UNIX is an OS on which Mac OS X is based upon, Intel is a company producing CPUs and Apple is using Intel CPUs since 2006 for their released products.
  5. gowguy thread starter macrumors newbie

    Jan 14, 2011
    to: simsaladimbamba

    Yes I tried Root or so I think I have.
    When I boot with Command 's' held down, I get a Terminal window and the prompt says: Root#.
    I'm assuming that is root, is it not? I really don't know but if it isn't, then how do I do it as root?

    I am going to the link you provided to see what that says but it looks familiar. Maybe there is something I have missed though.

    By the way, when I find information, some works and some doesn't.
    Example? The first command I found and tried with Terminal read: mount -uw
    but it didn't work. I noticed in my Terminal window that "it" said: /sbin/ first.

    So I tried that (/sbin/mount -uw) and was able to continue but the new password account didn't login. I'm at 10.5.2 (Leopard I suppose) but some commands don't work and trying some from 10.4 Tiger did allow me to go further and get a prompt to enter a new password. Still the password login failed.

    Example: for 10.5 Leopard
    dscl . -passwd /Users/username password - replacing username with one displayed or the one I want, didn't work, but instructions for 10.4 Tiger, i.e.

    passwd username hit enter - did allow me to enter a password and confirm it but I got the error messages I believe I posted.

    That's it for now. I'm kinda lost and confused as to how to get in and I really feel there is a way that also isn't so hard. But, I have to know what I don't know. That, is difficult right now.

    thanks much
  6. gowguy thread starter macrumors newbie

    Jan 14, 2011
    again to: simsaladimbamba

    I see we are online at the same time.

    I went to that link and it is about "root" from already being logged in and that is what I cannot do.

    Being here I am not at my iMac but perhaps foolishly, I tried entering username Root and then the password and clicked login but it froze. I think it was because the login window had one of the new User account names under the logo and that really confused it. So it froze, I had to cut the power and haven't rebooted since last night when I did this.
  7. simsaladimbamba

    Nov 28, 2010
    Do you have access to another Mac or maybe even Windows PC with Firewire?

    Btw, there is no need to double thread.

    PS: You can always do an "Archive and Install", where the old data gets moved into a "Previous System" folder and a new installation gets installed.
  8. old-wiz macrumors G3

    Mar 26, 2008
    West Suburban Boston Ma
    The X in OSx refers to the major release number "10", not Unix. Before OSx there was OS 7, Os 8, and OS 9. When it reached 10 they just said OSx.
  9. simsaladimbamba

    Nov 28, 2010
    I know that the X is the Roman numeral for ten, but it also alludes to Mac OS X' heritage in UNIX. I should have worded it better.
  10. gowguy thread starter macrumors newbie

    Jan 14, 2011
    simsaladimbamba Archive and Install

    Hi Again.

    I have been reading about "Archive and Install" but all I have found so far is a process that begins by already being logged in to the computer and that is precisely what I cannot do at the present.

    What exactly do you have in mind regarding access to another Mac? I have spoken with one tech here that works for or as reps for Apple and they told me they would just reinstall the system. That is what I am trying to get around first of all. Archive and Install sounds like it would work, they have Macs and perhaps this is the answer I've been looking for.

    Still, there is that part of me that wants to know what the heck happened?

    I may never know. Sorry about the double threads. I'll be more careful.

  11. simsaladimbamba

    Nov 28, 2010
    For an Archive and Install there is no need to be logged into the Mac. You just pop in the Restore DVD and boot from it and select Archive and Install from one of its options.
    Guide: +

    I thought about Target Disk Mode and you being able to connect the Mac to another Mac OS X or Windows computer and getting your data off before a wipe of the Mac OS X on your Mac.

    Do you know what could have led to this or what you did before the problem started showing up?
  12. Tyroler macrumors member


    Jan 2, 2011
    Hatfield, UK
    Have you checked your Account under "Parent Control" ?
    Think Window booted to Safe-Mode runs without Password,but im not sure and dont know how it is on Mac.
    Which Mac to you have?
  13. chrismacguy macrumors 68000

    Feb 13, 2009
    United Kingdom
    Parental Controls will have no impact here
    Macs require a password however you boot them, as does any PC thats been configured properly (Mine has everything locked down - safe mode, BIOS etc)
    He says he has an iMac G5 in the title, although its relatively immaterial as hes having issues with the Operating System.

    OP: Definitely use Target Disk Mode and get your data off, then Archive+Install and it should all be fine :)
  14. gowguy thread starter macrumors newbie

    Jan 14, 2011
    To: simsaladimbamba

    You asked?
    "Do you know what could have led to this or what you did before the problem started showing up?"

    I came back from an internet cafe with upgrades downloaded from (VLC), and apple (Quicktime and iTunes) and put them on my desktop then disconnected the USB.

    I installed VLC, with a restart, then Quicktime with a restart (I think), then iTunes and after typing in my Admin password, the install crashed. I tried again with the same results, shutdown and returned to the internet cafe for versions 8 & 9 of iTunes. When I booted up, typed in my password, I couldn't get in and the blue login button barely moves. Then I noticed that a user account name was showing under the Apple logo and that is not the way I had set up my login window. I realized that I might have typed in my original account user name and password for the wrong account, so I tried the name and password for the User account name that was showing, but with the same results.

    After that, I began trying to research and find some Terminal help that might work. I don't do too much as I don't know Terminal but one time I was able to see a listing of all my accounts (including the two new ones I tried creating), with the long and short names and noticed higher up the Terminal window the following: Unknown User

    Have no idea what that is. I remember, I think, that there are other users, my accounts, Admin, root and group, etc but I don't know what this "Unknown User" refers to. And I don't know how to look deeper into it with Terminal commands or whether or not I should try and remove or delete it.

    That's about it for now. When I boot from the install CD and go to Utilities, any thing I do freezes and I have to unplug or turn it off to get out.

  15. gowguy thread starter macrumors newbie

    Jan 14, 2011

    Well, I will read up on this Target Disc Mode. It sounds promising. I bought my G5 in May 2004, so I think it may have been 10.4 at the time and I upgraded to the 10.5.2 it is now. You know, when I booted from the install disk once, I went to Startup Disk and noticed it said 10.5.1, though the install and upgrade disks definitely say 10.5.2. Oh well.
  16. gowguy, Feb 11, 2011
    Last edited: Feb 11, 2011

    gowguy thread starter macrumors newbie

    Jan 14, 2011
    Can't login follow up

    Hello to all.
    I am going to try Target Disk Mode next week at a shop. I've read up on it and it sounds as though it will work fine.

    So, thanks to all those who helped me, gave out information or even swapped ideas through your dialogs. That is where or how I found the words Target Disk Mode, did some research on it and, well, we will see next Tuesday.

    Gotta go.

    I'll let you know and thanks again.

Share This Page