Cannot Login After Using Reset Password - Pinwheel, Black Screen, Back to Login Screen

Discussion in 'macOS Sierra (10.12)' started by Rex32, Jul 31, 2016.

  1. Rex32 macrumors newbie

    Joined:
    Aug 11, 2011
    #1
    Hey All,

    I'm having an issue with logging into one of my accounts on my MBP running 10.12 after using the password reset tool from another admin account. So basically I have Admin1 and Admin2, I was logged into Admin1 and preformed a password reset on Admin2 (which was linked to that users iCloud and shared the same password). Now whenever Admin2 tries to log in, I get a quick 2 second or so pinwheel followed by a full black screen with the cursor visible for another 2 seconds or so followed by a return to the main login screen.

    I've also tried using the quick user switch once logged in as Admin1 to go to Admin2 but I get an endless pinwheel (let it sit for an hour)...

    Tried booting into Recovery Mode and using Terminal and 'resetpassword' but I am prompted to enter the password to unlock the volume 'Macintosh HD'. That is the name of my disk volume but it isn't locked and I tried the Master Password as well as removing the Master Password.

    I've tried a ton of different passwords, and even no password... All to no avail.

    Any ideas apart from waiting for the official release as Apple suggests?

    And no, I don't have a TimeCapsule backup - stupid I know, but I don't have one.

    I've tried a few other things but nothing that has worked yet. I can't find any info on being prompted to unlock the volume using the resetpassword command in recovery mode and FileVault is not turned on and never has been.

    Sorry for the long post! Thanks for the help!


    -Rex
     
  2. Camato macrumors member

    Joined:
    Aug 16, 2013
    Location:
    Germany
    #2
    Had the same problem. Wasn't able to log in after restart, with same symptoms. All I could do was the internet recovery, alt+cmd r, and setup as new mac.
     
  3. X3n0n macrumors member

    X3n0n

    Joined:
    Jul 24, 2016
    Location:
    France
    #3
    Have you installed DuetDisplay ? Some users had the same probem with this .kext.

    After removing it, login works.
     
  4. Rex32 thread starter macrumors newbie

    Joined:
    Aug 11, 2011
    #4
    Thanks for the input. I don't have DuetDisplay so that wasn't it...

    But... Beta 3 fixed it. I installed it today on a new Admin account I created and after a reboot was able to log into the Admin2 account that was messed up before. Not sure what was wrong or how it was fixed, but PB3 fixed it :)

    Thanks for the help!


    -Rex
     

Share This Page