Cannot open ANY folders/files/apps in 10.5 ??

Discussion in 'macOS' started by addz, Jun 16, 2008.

  1. addz macrumors member

    Joined:
    Aug 8, 2007
    #1
    Here is the problem.

    Last night turned on the mac, go to open a folder or a file or even an app and nothing opens. I double click on any folder in Leopard and it just does not open. I can open the folder using cmd+o, the folder opens but their is no contents in the folder; pressing cmd+i though shows that their are files in the folders.

    Another strange thing is when i open the finder and select applications for example their will be nothing in the folder, but come a few seconds later and i go back to open the applications folder, all the contents are their but cannot open any apps.

    I just cannot wrap my brain around it. Ive tried repairing permissions, restarting the finder app, but nothing.

    Im using 10.5.3 btw. And the only way i can open a folder and see its contents is via quicksilver.

    Any help appreciated. :confused:
     
  2. notsofatjames macrumors 6502a

    notsofatjames

    Joined:
    Jan 11, 2007
    Location:
    Wales, UK
    #2
    thats an odd one. First, try restarting if you havent already. You could also try checking you hard disk using disk utility. If you cant get it to work from your system, boot from the DVD and run it from there.
     
  3. addz thread starter macrumors member

    Joined:
    Aug 8, 2007
    #3
    I manged to open disk utility with quicksilver. I ran verify disk and it found the following:

    Checking Extended Attributes file.
    Incorrect number of Extended Attributes
    (It should be 3446 instead of 3420)

    The volume Leopard needs to be repaired.
    Error: Filesystem verify or repair failed.


    I guess i should run disk utility from the disk, then it may allow me to repair the disk. I shall report back...

    EDIT: I repaired the disk successfully when booting up from the leopard DVD. But unfortunately i still have the same problem.
     
  4. jayhawk11 macrumors 6502a

    jayhawk11

    Joined:
    Oct 19, 2007
    #4
    That is really odd. Especially if you ran a repair. Have you repaired permissions yet? It probably won't fix this issue, but you might as well cover all your bases before we start talking about reinstalling Leopard or anything like that.
     
  5. addz thread starter macrumors member

    Joined:
    Aug 8, 2007
    #5
    Repaired permissions and did it successfully. I can now open the files on my desktop (but i do not think this was down to repairing permissions since when i restart its all problematic again) as well as other places e.g. my documents, movies etc. But if something is in a folder e.g. /documents/work, the work folder would open but not show its contents.

    BUT. Now give it a few seconds and i go back to that folder, the contents are displayed.

    Something strange is going on. 1 min no items in a folder then the next min there are items in the folder. :mad:. But when i restart everything goes back to how it was in my first post.
     
  6. addz thread starter macrumors member

    Joined:
    Aug 8, 2007
    #6
    I don't particularly want to reinstall leo, but it may have to be the case. Although pretty time consuming since i have bootcamp set up as well.
     
  7. AdeFowler macrumors 68020

    AdeFowler

    Joined:
    Aug 27, 2004
    Location:
    England
    #7
    Restart holding down Command-S
    At the prompt type:

    fsck -fy

    and press return.
    When the drive's successfully repaired type reboot and press return.

    If this fails re-install Leopard :(
     
  8. addz thread starter macrumors member

    Joined:
    Aug 8, 2007
    #8
    ^ says its found no problems/everything okay. Still getting same problem though.

    Appreciate all of your help, but still no luck. I have never come upon such problem before.

    Guess i am gonna go prepare for a reinstall. :rolleyes:
     
  9. shfawaz macrumors newbie

    shfawaz

    Joined:
    Sep 8, 2007
    Location:
    Detroit, MI
    #9
    I'm having the same exact problem. Booted using TechTool Pro 4.6.1 and that was no help despite it supposedly fixing the directory structure. This follows my upgrade to 10.5.3 only 48 hours earlier. Still haven't run from the Leopard disk, but thats next. I'm not holding much hope.

    I'm also getting the incorrect number of access control lists as well when I run verify disk. It says: "(It should be 0 instead of 29791)

    Checking Extended Attributes file.
    Incorrect number of Extended Attributes
    (It should be 1 instead of 32998)
     

Share This Page