OS X cannot open (run) steam on my mac after last update (27/03/2013)

Discussion in 'Mac and PC Games' started by sradja, Mar 31, 2013.

  1. sradja macrumors newbie

    Joined:
    Mar 31, 2013
    #1
    I am trying to open steam on my mac but when i am trying to open steam it appears on my dock for less than a second and then disappears and does nothing. I reinstalled steam, I used disk utility (repair) but still nothing. Could you please help.
    I have to notice than this happened after the last update of steam completed (?).
     
  2. SingularityG macrumors 6502

    SingularityG

    Joined:
    Jun 7, 2012
    #2
    Steam is working fine over here. However, I did have a similar problem some time ago in Windows.

    If I remember correctly, I had to uninstall Steam, then delete ALL remaining Steam files and registry entries. After that I just did fresh install and it worked again.

    In OS X, Steam is located in Library/Application Support/Steam.

    Word of caution: Library/Application Support/Steam/SteamApps/common folder contains your downloaded games, so I'd recommend to make a back up of that folder, before doing anything.

    Also, be sure to empty the Trash to completely remove the files.

    If you are unsure about this, best to contact support.:)
     
  3. sradja thread starter macrumors newbie

    Joined:
    Mar 31, 2013
    #3
    I am afraid that is not working for me. I've tried many 'methods' but still nothing (including yours).
    I also click steam on MacOs folder (osx32) and this message appeared

    ast login: Sun Mar 31 15:45:15 on ttys000
    iRadja:~ srantavellas$ /Applications/Steam.app/Contents/MacOS/osx32/steam ; exit;
    [2013-03-31 15:52:23] Startup - updater built Mar 25 2013 21:40:05
    found breakpad via in process memory: '/Applications/Steam.app/Contents/MacOS/Frameworks/Breakpad.framework/Versions/A/Resources'
    Installing breakpad crash handler
    Looks like steam didn't shutdown cleanly, scheduling immediate update check
    SteamID: 0, universe Public
    [2013-03-31 15:52:23] Checking for update on startup
    SteamID: 0, universe Public
    SteamID: 0, universe Public
    SteamID: 0, universe Public
    Killed: 9
    logout
    I sent (support) a message on 27th and I am still waiting for a reply ....
     
  4. yossiri macrumors newbie

    Joined:
    May 3, 2013
    #4
    I am having the same problem.
    Did you already know how to do?

    Please, I want to play a game so much.
     

Share This Page