Cannot pair Plantronics BUA-100 dongle with Discovery 925 to use on my iMac

Discussion in 'Mac Accessories' started by aquasky, Mar 16, 2009.

  1. aquasky macrumors newbie

    Joined:
    Dec 22, 2008
    #1
    I have bought the BUA-100 dongle to use with my Plantronics Discovery 925 so that I am able to use the Discovery 925 with my Skype on my iMac, but I cannot get the two to pair.

    I have already paired Discovery 925 to my Nokia mobile phone, which works perfectly with the phone, but it just does not want to pair to the dongle.
    I have already activated the multi-point bluetooth feature on Discovery 925 - does not solve the issue. I also tried deleting the headset from my mobile phone and then pairing it 'as first device' to the Dongle - no luck.

    As my Mac itself obviously does not recognise the headset (there are various discussions ont this), so the only way I can use my headset with Skype is to pair it to BUA-100 dongle for which I have just paid GBP45. But even this does not seem to work.

    What I do:
    I plug the dongle into an empty USB slot in my iMac, it starts flashing blue (as far as I remember). Then I pinch the small button on the dongle, it starts flashing violet/red (or something similar) I suppose indicating pairing mode. Then I switch on my Plantronics 925, but nothing happens. Neither the dongle nor the headset shows any signs of pairing. The dongle just keeps flashing violet/red for about a minute or two, and then stops. When I select the BUA-100 as input/output in Skype's Audio preferences - I hear absolutely nothing.:mad: Mic does not work either.

    Has anyone experienced this? Does anyone know how to solve it? Maybe faulty equipment (my dongle came in a bit of a makeshift packaging with no instructions)? I thought maybe once I paired my headset to a phone it won't pair to anything else (ever?). Surely this cannot be right.:confused:

    Any help much appreciated.
     
  2. aquasky thread starter macrumors newbie

    Joined:
    Dec 22, 2008
    #2
    This is now all sorted. Just needed to hold down the power on/off button for long enough... ;-)
     
  3. ksawyer macrumors newbie

    Joined:
    Jul 11, 2008
    Location:
    East Tennessee
    #3
    Pairing plantronics headset & freezing internet

    I just bought a Plantronics .Audio 995 and have trouble using it while watching streaming video. It freezes my internet connection when I change Input/Output settings in System Preferences to use the Plantronics headset. Otherwise it works great with Skype and iTunes and we're very pleased but first we had to manually pair the dongle with the headset. I've tried to get the Bluetooth Setup Asst. to find the headset to see if that helps my problem, but it just searches and searches and then reports an error.

    Manual Pairing: we had to hold down the power button on the dongle AND the power button on the headset until the blue light on the dongle flashed. Then everything was fine.

    Anybody have any fixes for the internet freezing issue?

    Thanks,

    Kim Sawyer
    MacBook Ver 10.5.5
    2 GHz Intel Core Duo
    2 GB Ram
     

Share This Page