cannot reach lan server

Discussion in 'iPhone' started by Daniel Santos, Feb 14, 2017.

  1. Daniel Santos macrumors newbie

    Joined:
    Nov 1, 2012
    Location:
    Portugal
    #1
    Hello,

    I have a home network with a wifi router that is also connected to a switch by ethernet. Connected to the switch are some mac pro servers and a powerline adapter plugged to a Wall socket. On another room connected to another Wall socket is another power line adapter connected to a Windows 7 box.

    I have an application on the Windows box that listens to http calls on port 45000. The Windows firewall is disabled. The purpose is to connect an app from the iphone on the wifi network to this port on the Windows box. My laptop is a macbook pro connected to wifi just like the phone. From the laptop I can reach the Windows box and telnet to the 45000 port. From the phone I can't. I installed a telnet app on the iphone, and can telnet to the router. From the routers admin Shell I can ping the Windows box. But from the phone directly to Windows I just get a timeout.

    Is there any particular aspect on the iphone's networking that causes it to not play well with the router ? It is a thomson (can't remember the model, will post it in case anyone asks for it)

    Thanks
     
  2. dmylrea macrumors 68020

    dmylrea

    Joined:
    Sep 27, 2005
    #2
    From your phone, on WIFI, can you ping the windows box or the router? I suppose it's possible that the iPhone is using cellular instead of WIFI, in which case it will never hit your LAN.
     
  3. Daniel Santos, Feb 14, 2017
    Last edited: Feb 14, 2017

    Daniel Santos thread starter macrumors newbie

    Joined:
    Nov 1, 2012
    Location:
    Portugal
    #3
    When I try to connect I have both cellular and WIFI enabled and am on my router's wifi network. I can reach the router, and from the router's admin shell I can ping the windows box. But I cannot connect directly from the iphone to the windows box.

    When I try the same connection from my MBP which is also on the same Wifi network the connection succeeds.
     
  4. BrianBaughn macrumors 601

    BrianBaughn

    Joined:
    Feb 13, 2011
    Location:
    Baltimore, Maryland
    #4
    Have you tried to ping the Windows box using a different app on the iPhone (such as "Fing")?
     
  5. Daniel Santos thread starter macrumors newbie

    Joined:
    Nov 1, 2012
    Location:
    Portugal
    #5
    I installed Fing and it can reach the server. Guess something's wrong with the free terminal app I downloaded before.
    Anyway, I wanted to connect a free app on the iPhone to my DAW on the windows box. That app cannot detect the server.
    I then proceeded to buy the payed version of the mobile app, and that one can see the windows box.
    So after spending some $$, problem solved

    Thanks for your help
     

Share This Page